I have built 16/16 imperial levels, however the death Star behind the emperor is not complete (missing a small portion on the top). More disconcerting is that the imperial "mission" tells me I must build another imperial level in order to see what I must build next. It costs 100 bux to skip. Is this a bug, or is it simply wanting something from the "coming soon"future updates? Has anyone else experienced this or found a fix besides paying to skip (which may result in it happening again)?

  • I tried the $100 skip and it just crashes the program every time. This sucks and I'm probably going to stop playing it because of this.
    – user66031
    Jan 6, 2014 at 13:27
  • @Rob - Does it still take your 100 Bux? Or is it crashing before that point?
    – David M
    Jan 8, 2014 at 18:40

1 Answer 1


Tiny Death Star is still receiving updates occasionally, which add more levels - including Imperial levels. It's certainly possible that such a new Imperial level might enable you to complete this mission in the future.

It is also very much possible for the emperor to ask for a currently impossible level to be built. This could be considered an oversight or a bug - neither of these is confirmed and we can't really look into the developers' minds on this. Support for Tiny Death Star is also abysmal.

If you wish to proceed with the missions, you will either have to wait for an update that adds Imperial levels, or skip the (costly) mission.

  • Has anyone ever tried to skip the hundred bux mission? I'm worried that skipping that mission will just bring another of the same and that they're currently aren't any other missions.
    – Cade Roux
    Jan 4, 2014 at 14:27
  • I'm going to do it. The game is getting stale for me anyway. I'm still at 50 BUX, but when I hit 100, I'll do it in the name of science.
    – David M
    Jan 5, 2014 at 19:59
  • 1
    I tried skipping for 100 bux just now and can confirm it will crash your game. Game will reset to a bit before you spent the bux, and the imperial money making machine you focused on is now worthless :(
    – user14461
    Jan 12, 2014 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .