I read here that the DS4 will work on Mac out-of-the-box by plugging the controller via a micro USB cable—they said it will automatically work as a regular joystick.

I got the DS4 yesterday (controller only, no console) and tested it on my Mac but it doesn't seem to work. The computer detects the controller but the games I have doesn't seem to recognize any inputs on the DS4. I tried the controller on Fez, Rayman Origins and Monaco—which all have joystick support—but no luck.

Also tried mapping the controller thru Joystick Mapper, it will say "1 Joystick Connected" but when I try to bind the controller, click "scan" while clicking a button on the controller, nothing.

I've read on the manual that comes with the controller titled "Registering (pairing) the controller" that there is a need to pair it on the PS4 console to complete registration. Is this a requirement for the controller to work?

It's either that is the reason why it's not working or the DS4 is just not compatible with my games (I think it should be tho, since it's supposed to work as a regular joystick when plugged thru USB cable).

  • 1
    The DS4 is a DirectInput device. Maybe the games you're trying to run are XInput ones? At least, that's the problem on Windows: the DS4 is DirectInput, but most games are XInput. Since XInput is made by Microsoft specifically for the Xbox 360 controller, I'm not sure if that's the same problem you're having on Mac. This question has a solution that works with Windows, maybe it will work for you too?
    – Nolonar
    Dec 22, 2013 at 19:20
  • Oh thanks, that makes a lot of sense. I guess, will just wait for Sony to release official drivers (which I'm not hoping will come any sooner) for the controller to work. Or similar wrapper for Mac described on that answer. Or wait for games to add DirectInput controller support. Ugh, I could have just gone with the wired 360 controller in the first place. :( Dec 23, 2013 at 2:38
  • @kevinandrada except xbox 360 controllers suck
    – Almo
    Jun 16, 2017 at 23:54

2 Answers 2


Okay, so I found out the problem, it is due to an app called USB Overdrive taking precedence over the controls of the DS4 controller. If you're like me and you happen to also have a gaming mouse (with no driver support from the maker, pffft Roccat Kova[+]) for FPS games, this app is probably installed on your Mac.

On USB Overdrive settings, don't enable "Any Gaming, Any Application". This is the culprit.

I tried the controller on Steam's Big Picture and also Monaco after and it worked.

  • That's a pretty specific situation... it deserves to be documented.
    – Coyote
    Dec 23, 2013 at 21:05
  • In monaco, don't you have any issues with the aiming direction being bound to the triggers?
    – Coyote
    Dec 23, 2013 at 21:06
  • 1
    Yes, the controls on Monaco is not mapped properly on DS4. E.g. the directional pad is not working but the left analog stick is, for moving the character. This is better than a non-responding controller at all, right? And hey, thanks Coyote for all the help! Rayman Origins (Feral game) is now working too. :) Dec 24, 2013 at 4:29

The Dualshock 4 works with some games.

In some cases it works but only with the USB cable, but if you want to pair the controller over bluetooth anyway, follow this procedure from mactrast:

  • Open Bluetooth preferences on your Mac.
  • Put the DualShock 4 into Pairing mode by pressing and holding the PlayStation and Share buttons until the light bar blinks rapidly.
  • Wait for the Wireless Controller device to show up in Bluetooth (select Add Device in OS X Mountain Lion or earlier – shows up automatically in Mavericks).
  • Select “Wireless Device” and click Pair. The process will now complete automatically.

Feral interactive is rolling out native Dualshock 4support for most games. Currently the .plist file can be obtained by contacting [email protected].

There is an older version of the plist while we're waiting for proper patches. To add it to your games follow this procedure:

  • Find your copy of your Feral Interactive game (usually in the Applications folder).
  • Right click (or ctrl click) and click “Show Package Contents” from the dropdown menu
  • Open the “Contents” folder, then the “Resources” folder and finally “Input Devices”.
  • Drag the attached PS4Dualshock.plist file into the folder (you will be asked to Authenticate using your username and password, please do so).

I tried this file with Dirt 2 and it works (over USB). Have fun!

One thing I also added to this procedure:

  • After adding the plist Right click (or ctrl click) on the “Input Devices” folder and click “Get Info”
  • In the new window under "Sharing & Permissions:" unlock changes (click on the lock in the right corner)
  • Enter username/password (if requested)
  • Under the Users/Privileges list click on the Options Button
  • Select "Apply to enclosed items..."
  • Coyote, thanks! That's exactly the guide I followed, from MacTrast. I tried both. Even with Option 1 tho, I cannot seem to make the controller work on Steam's Big Picture or any of my games. I think the comment of Nolonar above is the reason why. Also, I emailed Feral yesterday for that plist, still got no reply from them. Thank you for the download link! Will try. Dec 23, 2013 at 2:45
  • Tried adding the "plist" on Rayman Origins, the controller still didn't work. I own the controller only / don't have the PS4 console so I did not complete the registration according to the controller's manual. I am now assuming this has a factor why the controller is not working. Dec 23, 2013 at 3:06
  • @kevinandrada Try changing the permissions as in my edit.
    – Coyote
    Dec 23, 2013 at 7:21
  • Still did not work. I did all the exact instructions. :( Dec 23, 2013 at 7:44
  • @kevinandrada If the controller has already been paired with a PS4 try un-pairing it (reset). Try also in steam big picture to configure the controller in the options. It took a few tries before I got it to work in steam... And after that it doesn't work at all or badly in many steam games.
    – Coyote
    Dec 23, 2013 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .