2

Just got this game of the sale, looking forward to playing it.

Unfortunately, I've received massive stutering and lag issues. I have a pretty amazing gaming rig, as I can run BL2, AC4 at max to high settings with no stutter. So this shouldn't be an issue for me.

From what I can tell online, there's also very few solutions out there. One of the options was to edit registry settings, but that doesn't change a thing still.

Any way I can optimize the game to remove this "lag"? It's plenty annoying, and the problem doesnt seem to go away even when I lower the settings down to nothing.

  • I also have been having this problem. Tried all the registry fixes from around the internet and they don't help. It's quite annoying since I could run the original 60+ fps with maxed settings and was really looking forward to this one. – Dustin Jan 15 '14 at 2:54
  • @Dustin Exactly my sentiment. I think I managed to get things smoothed out by going into my Nvida Control Panel and making sure the game was manually using the graphics card, but even then I would still get these constant stutters. – senpai Jan 15 '14 at 3:56
  • Looks like we have more than one problem in common. – Dustin Aug 6 '14 at 2:38
2

Assuming you have a NVidia graphics card (which is what normally causes this problem) you can make the following registry change to resolve this issue:

Open the Windows registry editor:

  • Open the Start Menu
  • Type in regedit.exe

For the original release:

  • Go to HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR

For the Director's Cut:

  • Go to HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HRDC for Director's Cut

Change this value to 1 to disable graphics optimisations:

  • Set D3D11_CREATE_DEVICE_PREVENT_INTERNAL_TH­READING_OPTIMIZATIONS to 1

Alternatively, if the above doesn't resolve the issue for you, you can also try setting the following values as well - this should work regardless of graphics card vendor;

  • In HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HRDC, locate AllowJobStealing and set it to 0

Finally, specifically for owners of NVidia graphics cards;

  • In HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HRDC\Graphics, locate AtiForceFetch4 and set it to 0

For the original release of Deus Ex: Human Revolution, change the above registry keys from HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HRDC to HKEY_CURRENT_USER\Software\Eidos\Deus Ex: HR.

  • I've done that before, from what I can find online, and I still get massive stuttering issues. If I run in a straight line without looking around I can get no lag, but once i turn a corner or look around, it stutters up again – senpai Dec 24 '13 at 9:14
  • Added a couple more things to test – kalina Dec 24 '13 at 9:45
  • Tried those, still getting random framerate drops for same reasons. Otherwise, everything else is fluid. computer isn't overheating, and I'm using a fan, so i don't think there's any problem with cpu temp – senpai Dec 25 '13 at 9:43
1

A couple more solutions from around the internet, which I'll offer up. They didn't work for me but apparently they work for some people.

  1. Run Google Chrome in background
  2. Use the app from http://www.lucashale.com/timer-resolution/ and set it to the highest setting, it changes the timer
  3. Change from fullscreen to windowed, and then alt-tab back to the game again so it'll go fullscreen
  4. Turn off triple buffering

Love to see some more suggestions.

-1

Nvidia users can also try this (and it works for all games):

  • Disable in game VSYNC
  • Enable VSYNC IN Nvidia Control Panel (On or Adaptive).

It can even double the frame rate in some games (for example WRC4).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.