6

I'd like to launch Left 4 Dead 2 with option -affinity 1,so I would not have to set CPU affinity manually every time. But when I try to set it in shortcut,I can't launch the game and when I put it in Steam properties,It doesnt work. Is there any way to set it to game icon ? Thanks for help

1
  • 3
    In case it matters, I'd suggest mentioning what OS you're using.
    – Foon
    Dec 28 '13 at 13:42
5

Ok, I've run into the same problem with Steam games. The problem is that steam.exe spawns the game process, not Windows directly, and Steam doesn't pay any attention to the /affinity switch. So it can't reliably be set in the shortcut OR in Steam's "advanced" options. Whatever processor affinity steam.exe has, all games launched from it will also have.

The only way I've found to get a 100%-working solution is to use the Microsoft Application Compatibility Toolkit (free download from Microsoft). There is a fix called "SingleProcAffinity" which will guarantee that a process launches using only one CPU. It's a bit complicated to set up and get working the first time, but unfortunately it's the only solution I've found that doesn't make you go back to the Task Manager on every launch.

4

Friend of mine helped me with this. Path for shortcut is:

C:\Windows\System32\cmd.exe /c start /affinity 1 "C:/Progra~2/Steam/steamapps/common/Left4D~1/left4d~1.exe" -steam

Then it will launch in steam correctly, but with the CPU affinity set to 1 Core.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.