I have looted every chest in AC4 Black Flag. But the last chest at location 688,904 won't open. I walk to the chest, there is a loot option. But when I press the button to loot Edward just kicks the chest and nothing happens. Is this a bug? Please help.

5 Answers 5


Use the Eagle Vision then open the chest normally. It worked for me!


You might be on the wrong side of the chest. Try walking around. Although the loot button might look activated, you need to see the indicator above the box before you can loot it.

Also make sure you're at the right box. Try locking onto the box location on your map. Then you can see your distance from it and make sure you're at the right one.


Eagle vision on, right infront of the chest and hold the loot button. The eagle vision slows Edward just enough to complete the action before he returns to the hidden position. Takes a few kicks but it gets there eventually


Try moving the camera to the opposite side while pressing the 'loot' button. It should work. Just keep pressing the 'loot' button and move the camera to the opposite side or keep the camera rotated.


You have to hold the interact button which is by default E and while holding that button press Alt+Tab to go to the desktop and again use Alt+Tab to go back into the game. It should open. Well, it worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .