1

I have an issue with my Minecraft launcher - I downloaded modpack for minecraft then the launcher started an update for the modpack version which it's 1.6.2, however then I started to get the issue

[15:40:59 ERROR]: Gave up trying to download https://libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar for job 'Version & Libraries'

[15:40:59 ERROR]: Job 'Version & Libraries' finished with 26 failure(s)! (took 0:01:06.362)

At the same time I had just downloaded Avira antivirus and ran it, but unfortunately removing it and trying again didn't help. I've tried to restore the system to the point before downloading the antvirus and the mod pack a 2 days ago, I've tried turning off the firewall and I have tried removing the whole .minecraft folder all with no luck at all. I can't figure it out, all the servers are working and I have good internet connection but some of the files download fine and other don't.

The full log is here:

[15:40:59 WARN]: Couldn't download https ://libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar for job 'Version & Libraries'
java.net.SocketTimeoutException: connect timed out
        at java.net.TwoStacksPlainSocketImpl.socketConnect(Native Method) ~[?:1.7.0_45]
        at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source) ~[?:1.7.0_45]
        at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source) ~[?:1.7.0_45]
        at java.net.AbstractPlainSocketImpl.connect(Unknown Source) ~[?:1.7.0_45]
        at java.net.PlainSocketImpl.connect(Unknown Source) ~[?:1.7.0_45]
        at java.net.SocksSocketImpl.connect(Unknown Source) ~[?:1.7.0_45]
        at java.net.Socket.connect(Unknown Source) ~[?:1.7.0_45]
        at sun.security.ssl.SSLSocketImpl.connect(Unknown Source) ~[?:1.7.0_45]
        at sun.net.NetworkClient.doConnect(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.http.HttpClient.openServer(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.http.HttpClient.openServer(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.https.HttpsClient.<init>(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.https.HttpsClient.New(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) ~[?:1.7.0_45]
        at java.net.HttpURLConnection.getResponseCode(Unknown Source) ~[?:1.7.0_45]
        at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source) ~[?:1.7.0_45]
        at net.minecraft.launcher.updater.download.ChecksummedDownloadable.download(ChecksummedDownloadable.java:49) ~[launcher.jar:?]
        at net.minecraft.launcher.updater.download.DownloadJob.popAndDownload(DownloadJob.java:108) [launcher.jar:?]
        at net.minecraft.launcher.updater.download.DownloadJob.access$000(DownloadJob.java:12) [launcher.jar:?]
        at net.minecraft.launcher.updater.download.DownloadJob$1.run(DownloadJob.java:89) [launcher.jar:?]
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.7.0_45]
        at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.7.0_45]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.7.0_45]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.7.0_45]
        at java.lang.Thread.run(Unknown Source) [?:1.7.0_45]
[15:40:59 ERROR]: Gave up trying to download https ://libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar for job 'Version & Libraries'
[15:40:59 ERROR]: Job 'Version & Libraries' finished with 26 failure(s)! (took 0:01:06.362)
4
  • 3
    It looks like a firewall or something is preventing Minecraft from connecting to the internet.
    – fredley
    Commented Jan 1, 2014 at 15:14
  • any help will be appreciated it's unfair at all buying minecraft it's crashes buying server and no one joins it making great tutorials and gets dislikes
    – alanazi
    Commented Jan 1, 2014 at 16:26
  • It doesn't look like this is Minecraft's fault; if its a firewall, that's something on your computer or network that's causing the issue.
    – Frank
    Commented Jan 1, 2014 at 16:47
  • 1
    Have you tried downloading the file from that link you posted: libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.5/… - if you can't download the file from a web browser, Minecraft will also be unable to download it, you'll need to resolve your network problem first.
    – Kcats
    Commented Jan 2, 2014 at 16:28

1 Answer 1

1

The issue was that DNS I used, so I used Google's public DNS, which is free, safe and fast. You can use Google DNS here, and get troubleshooting help from here.

2
  • where do I specify the DNS server for minecraft?
    – user65957
    Commented Jan 5, 2014 at 16:31
  • @Mike DNS settings are changed computer-wide by going to your network adapter's properties.
    – Nathan C
    Commented Jan 17, 2014 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .