12

I downloaded Skyrim from Steam, and I have a few mods from the Steam Workshop.

I decided to start using the Nexus Mod Manager (0.46.0) only to find that when it scanned my games it showed the error message:

Unable to get write permissions for: C:\Games\Nexus Mod Manager\Skyrim\Install Info

I believe that I moved the file to the appropriate folder, etc. I'm sorry for being somewhat vague, but I am not computer savvy.

  • Welcome to Arqade. I've edited your post to make it a bit more clear for people trying to read it. Please take the time to read the tour section under the help tab. It's quite helpful for new users. – David M Jan 4 '14 at 5:30
  • What version of Windows are you running on? – Joe the Person Jan 4 '14 at 14:53
  • heh, why would you install games in system partition ? – Rusted_Silver Jan 4 '17 at 10:24
8

I ran into this problem today, and I've come up with a few solutions. The root cause is that the default folder that Nexus Mod Manager wants to install into is not typically writable by normal users. They want you to install into a subfolder of C:\, and if you don't have administrator rights, chances are you can't create the "Games" folder you need (C:\Games).

You've got a few options:

Run the program as administrator. This way, it will have permissions to write to the root of C:\, and then you can create the files/folders there. Just right click, and choose the "Run as Administrator" option.

Get write permission on C:\Games. You can do this if you have administrator rights by:

  1. Open your C:\ in Windows Explorer
  2. If the "Games" folder does not exist, right click, choose "New Folder" and name it "Games"
  3. Right click on the "Games" folder, and choose "Properties"
  4. Click the "Security" tab
  5. Click the "Edit" button
  6. Click the "Add" button
  7. Type your login name (if you log in as "bobsmith" then you'd type "bobsmith" here)
  8. Click "Check Names" and if the name becomes underlined, you did it right! Click OK. If not, double check your login name from step 7.
  9. On the bottom half of the "Permissions" dialog, click "Full Control" for the user you just added.
  10. Click OK to dismiss this dialog, and then click OK on the properties dialog.

Now you can write to C:\Games, which ought to make NMM happy.

Put your Nexus Mod Manager files somewhere else. If you install to some subdirectory of your home directory, you won't have to worry about permissions and so forth. When the Mod Manager asks you where you want to save the mod files, pick someplace under C:\Users(your user name)\ or C:\Documents and Settings(your user name), depending on the version of Windows you're using. You could potentially put this in your Documents folder, but I have "projects" folder I created in my home directory, which works well for me.

You do not want to set these directories to something under C:\Program Files or in the Steam folder, etc. This is a Bad Idea.

If you've already selected the default mod directories, you won't be asked if you want to change them when you get this error. If that's the case, you can edit or delete the config file so that you can pick a new directory.

The config file for Nexus Mod Manager is stored in %LOCALAPPDATA%\Black_Tree_Gaming - you can copy and paste this into the address bar of Windows Explorer to go there, or paste it into the "Run" or "Search" dialog on the Start menu. Alternatively, from your user's home directory, look for "AppData" and then "Local" and then "Black_Tree_Gaming"

The name of the directories in this folder depend on your version of NMM, but the file you're looking for is user.config. You can delete this file, but you'll lose any other NMM settings (including the location of any games that were scanned previously). You can also edit it with a text editor.

Look for a block that looks like:

    <setting name="ModFolder" serializeAs="Xml">
        <value>
            <PerGameModeSettingsOfString>
                <item modeId="Skyrim">
                    <string>C:\Games\Nexus Mod Manager\Skyrim\Mods</string>
                </item>
            </PerGameModeSettingsOfString>
        </value>
    </setting>
    <setting name="InstallInfoFolder" serializeAs="Xml">
        <value>
            <PerGameModeSettingsOfString>
                <item modeId="Skyrim">
                    <string>C:\Games\Nexus Mod Manager\Skyrim\Install Info</string>
                </item>
            </PerGameModeSettingsOfString>
        </value>
    </setting>

The directories here are the ones you'd want to change to some folder you can write to.

2

Check to see if your user account is listed and has full writing access and check if you are the owner.

There is a detailed explanation of how to do this located here.

  • @kotekzot Oops, my bad. I was just going to check that it worked, and you beat me to it! Thanks. – David M Jan 13 '14 at 14:34
0

Run the NMM as an Administrator. This will fix your problem.

  • 1
    I've already tried that, but it just gives me the same response, but thanks for the pointer. – Jack W. Jan 5 '14 at 0:32
0

I would never run any code/program as administrator (and I would disable UAC)

unless you fully trust the code and all libraries that are loaded by said code

just to overcome a permissions error such as:

Unable to get write permissions for: 
C:\Games\Nexus Mod Manager\Skyrim\Install Info

This would also be just like running code as root on linux/mac

The correct remedy for this would be to grant yourself write permissions to 'Games' and all sub-folders (including files) -- also you would want to take ownership of the folders.

The reason why it is a bad idea to run a program as an administrator is
because the program (and any dll/library that gets loaded) will have elevated privileges.

While in most cases that won't be an issue, but if someone has modified a dll/library with malicious intent -- then what ever code the library contains will run with elevated privileges [on windows UAC is not adequate enough to prevent it, since it won't catch code loaded from a library].

PS: UAC is designed to make it convenient to execute code with elevated privileges (even if your are not an administrator). This is another attack vector that malicious entities can use to get code to execute on your system (without being an administrator).

http://blog.cobaltstrike.com/2014/03/20/user-account-control-what-penetration-testers-should-know/

-1

Just run as admin that helped me

  • While I agree that probably should work, could you elaborate a bit? – Shadur May 17 '15 at 13:53

protected by Timmy Jim Apr 8 '17 at 20:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.