2

I bought Dragon Age: Origins - Ultimate Edition on Steam in the recent sale. When I try to run the game from Steam, I get the launcher. When I click play from the launcher, the launcher disappears and the game doesn't launch. I've tried going to the Steam folder and launching the DAOrigins executable, and when I open it nothing happens. I've tried reinstalling the game and I've tried running as administrator, both to no avail.

Is this a common issue? Is there a workaround?

  • 4
    What's your operating system? – Frank Jan 8 '14 at 2:30
  • 2
    Verify your game cache. – BadSnowflake Feb 7 '14 at 14:54
  • Disable your firewall to check if this helps; if it does, create an exception for DA. When I ran the game through origin some years back, this then was a "can't connect to origin" issue...I don't know if and how this applies when under steam. There was another similar issue I forgot, but it should be google-able from the origin/bioware forums (some networking setting that kept being unset for no good reason, and needed to occasionally be re-adjusted). The shell ea imposes on bioware games is awful, as you just realized. – gnometorule Nov 5 '14 at 2:04
  • What is the specs of your PC? – Ulfric Stormcloak Nov 5 '14 at 2:37
2

I had this problem as well. The problem is that Steam needs to do some special stuff it cannot do without admin privileges the first time you start the game, according to the solution I found. Starting the game as an admin is not enough, you need to manually close Steam, restart it using Admin rights, then launch the game. Subsequent launches do not require Steam to have admin rights.

Another solution I found while Googling when I had the issue was to close Steam entirely and use the installer directly from Windows, instead of the game library option. Don't worry, it still opens Steam first.

If you STILL have troubles after that, there's one last alternative: the key you get for the game is also valid for use in Origin, so you can try activating it through there, downloading the Origin version (from an elevated Origin window), manually patching it to 1.05, then disabling cloud saves and putting the game to XP SP3 compatibility mode.

0

A friend of mine had this problem. He claims that he fixed it by setting both the game (dao.exe?) and the launcher to NOT run as admin.

I can't verify this as I've not tried it but it's a quick thing to try...

  • I always launch Steam as admin and no trouble starting that game this way. – BadSnowflake Mar 9 '14 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.