0

I followed a lot of tutorials, including Bukkit.org's steps like below:

  • 1.Create a folder with your choice of names
  • 2.Download the latest recommended build CraftBukkit.Jar
  • 3.Place the Craftbukkit1.6.4 jar from step 2 in your folder
  • 4.Rename CraftBukkit1.6.4-R2.0.Jar To CraftBukkit.jar
  • 5.Open Notepad and copy and paste java -Xmx1024M -jar craftbukkit.jar -o true PAUSE
  • 6.Save the Notepad text you just wrote and click save-as (Name).Bat (I did run.bat originally but it still never worked)
  • 7.Double-Click Run.bat or (Name).bat and it should load your world

*This is where it failed to load anything. The problem in every set of steps I try comes up when trying to run the run.bat file. No matter what I do I always get this: it says Java is not recognized

Does anyone have any idea why this happens, or how IO can fix it?

closed as off-topic by dly, Lore Friendly, greg-449, Joachim, JonK Jul 14 at 22:18

  • This question does not appear to be about videogames or videogame consoles within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Can you run basic Minecraft? If so, the problem is that Windows doesn't know where to find the Java executable. – Frank Jan 8 '14 at 2:38
  • I can launch the game, if that's what you mean. And I think I tried to make a vanilla server before and that worked, it's just the bukkit thing that doesn't seem to like me much. I'm on a Windows 8 if that helps. – Judal Jan 8 '14 at 2:40
  • Yup, sounds like Windows doesn't know where Java is. I'll let someone more knowledgable than I about that help you out. – Frank Jan 8 '14 at 2:43
  • Okay, thanks for your quick response though! Having even a basic idea of what's happening feels relieving. I'll keep waiting for another reply, thanks again. – Judal Jan 8 '14 at 2:44
  • 5
    I'm voting to close this question as off-topic because it's for modded minecraft tech support and we can only help with vanilla minecraft crashes. – Virusbomb Jul 8 at 14:50
1

The simplest thing to do is install Java again (java.com/getjava‎), then try again.

If this does not work, here is how to configure the server to use the same Java as the Minecraft client:

  1. Open the Minecraft Launcher
  2. Click on 'Edit Profile'
  3. Make sure 'Launcher Visibility' is set to 'Keep the lanucher open'
  4. Click 'Save Profile'
  5. Click 'Play' and wait for the title screen to appear
  6. In the Launcher window (which should be still open), switch to 'Development Console' tab
  7. Search in the last few lines the following:

    [08:54:24 INFO]: Launching in C:\Users\Ruehl\AppData\Roaming\.minecraft [08:54:24 INFO]: Half command: C:\Program Files\Java\jre7\bin\javaw.exe -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G ...(snip)... \.minecraft\versions\1.7.4\1.7.4.jar net.minecraft.client.main.Main

  8. Copy the part on the Half command: line before javaw.exe - in my case it is C:\Program Files\Java\jre7\bin\
  9. Put that path in the run.bat file before java
  10. (optional) Change 'Launcher Visibility' back to what it was
  • Okay awesome! It didn't work the first time but that's because I'm a silly derp that forgot the ;. Now my problem is it won't allow me to allocate more than one gig of RAM, even though I have 16 gigs. I want to allocate 8 if possible, but even 4 won't work. – Judal Jan 10 '14 at 3:16
  • @Judal You need to have 64 bit Java on 64 bit Windows to use more than 1400MB for Java – Kcats Jan 10 '14 at 8:29
  • Do I have to uninstall the 32-bit half of java to get it to work? Because I have 64 bit java too, and it doesn't work at all, and my windows is definately 64-bit. When I go to install Java it always instals both 31 and 64 bit versions – Judal Jan 12 '14 at 23:43
  • @Judal The default install location is C:\Program Files\Java\jre7\bin\ for 64-bit Java; and C:\Program Files (x86)\Java\jre7\bin\ for 32-bit Java. Other than that, I don't know how you can recognize it. – Kcats Jan 13 '14 at 15:36
  • Alright, found and uninstalled the 32-bit. It works great now, I guess it was just choosing 32-bit over 64 by default. Thanks for all your help~ – Judal Jan 13 '14 at 21:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.