0

My Starbound server is not working; when I try to log on to the server it says "wrong password" but I have not set a password. My friend can join but I can't. Does anyone have any ideas what to do?

  • On what OS you are running the server? Windows, Mac OS, Linux 32 or Linux 64? Your friend conects to the same server? – Joe Scylla Jan 16 '14 at 12:28
  • Figured out what was going on guys. i found that i had to run the server and fully load it up before starting Starbound. i have this feeling that it was some interruption with running the server and Starbound at the same time. – Antp Jan 22 '14 at 21:13
1

In the default_configuration.cfg file there should be this code:

"serverPasswords" : [
  "",
  "duckies",
  "swordfish",
],

Which denotes the blank password, and the two default passwords. Either try one of the default passwords, or delete them all and create your own.

  • i have deleted both of them so the server has no password but it dose not work for me. but for my brother it dose. its so annoying iam ripping my hair off!! – Antp Jan 8 '14 at 22:11
  • Try setting a password, and see what happens then. – Michael Frank Jan 8 '14 at 22:12
  • I tryed but it's still telling me Wrong password. – Antp Jan 8 '14 at 22:17
1

As of 12 Feb, 2015...
Modify the "serverUsers" entry in the starbound.config file.
More specifically, <SteamApps>/common/Starbound/giraffe_storage/starbound.config
I'm guessing here, but I imagine giraffe_storage will change with future patches.
Here's an example:

"serverUsers" : {
  "fred" : {
    "admin" : true,
    "password" : "hunter2"
  },
  "george" : {
    "admin" : false,
    "password" : "swordfish"
  }
},

Check the dev blog post for more info:
http://playstarbound.com/february-17-server-configuration-changes/

-3

what ip are you using. if your NOT using your ipv4, USE it. when you use your ip address your telling your computer to talk to itself. if you use your ipv4 it should be fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.