I started to have weird kind of issues with the Star Wars: Tiny Death Star game. Since few days ago the game behaves like that Game Center integration is not working correctly.

First symptom was I could not open Levels and Album as if it would be locked like at the beginning of the game. Then I started to receive tips like from beginning of the game (like that if I deliver ? bitizen to the right floor I could unlock some scene) and then I started to receive achievements I already had (like 100k credit, captured rebel hero or set of rebel heroes - everytime I met the requirements - again and again).

I tried to restart game, restart phone, relogged into Game Center, then restarted everything again. No improvement.

It looks like that game is storing some information into Game Center and suddenly it lost ability to read it back. However I am getting welcome back into Game Center message during start of game and if I log out I am asked to login during game start-up.

I already opened support message for this...

Question: Am I the only one impacted or this is system wide error? Is anyone else have same problem?

iOS version: 6.1.3

Device: iPhone 4

Thank you.

1 Answer 1


There have been an ongoing issues with Tiny Death Star and Game Center. People have reported multiple instances of not receiving their achievements via Game Center.

But, you seem to have a bigger issue with your installation. The other symptoms seem to speak to a corrupted file somewhere. And, given the limitations of iOS, I don't think it will be easily repaired.

In my experience, you have done everything from your end that you can, except: uninstalling the game, and restarting the game from scratch, including clearing it from Game Center when you do so. This solution has worked for other users experiencing a wide variety of game play issues. But, it will also delete all of your progress.

I'm sorry there isn't an easier solution. Hopefully a future update will address this.

  • Using your own criteria, your answer also does not answer the question. Your case is really worse because you can't even reproduce the issue so claiming knowledge of how to solve it/root cause is complete speculation.
    – HotinRhino
    Commented Jan 12, 2014 at 19:00
  • @HotinRhino I have made it clearer that this is based upon my experience with the game. And, the difference between my post and the previous post is that the other post does not offer any solutions (tested or otherwise). The full uninstall has worked for other posters experiencing a wide gamut of problems. And, given the symptoms the game is exhibiting, this strikes me as the only solution.
    – David M
    Commented Jan 12, 2014 at 19:42
  • 1
    Thanks a lot for tips and effort to help me. I am really disappointed by Disney. This seem to be official game of big know brand. They even invested into TV advertisement, etc. But quality is far behind the buzz Disney is making. As you add the level the game performance is noticeabley going down (regardless of fact that graphics is quite primitive - no 3D effects) and it also seems that it is having a lot of bugs... I would expect more from such known brand. I am going to wait few days and then I will probably write review on iTunes warning other interested gamers.
    – user66526
    Commented Jan 13, 2014 at 8:17
  • 1
    The graphics quality is intentional. It's meant to be "old-school 8-bit". Everything else you've said is 100% accurate! They are not putting any effort into supporting their software!
    – David M
    Commented Jan 13, 2014 at 11:13
  • 2
    I understand that graphics is intentionally primitive and it is ok. But I would then expect whole app to be superfast because it does not need to render complex graphics. Like you said game is like on "old-school 8-bit" but performance requirements are from 21st century. This looks to me like poor optimization - dev teams did not spend much time on the app as it is buggy and with performance problems...
    – user66526
    Commented Jan 13, 2014 at 16:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .