2

Today I received a notification from Tiny Death Star.

TDS

Now, this came as a surprise because we've all tried to get the Snowtrooper to unlock Scoop of Hoth in the past, but without success.

In fact, after receiving this message, I attempted to use the Snowtrooper ? bitizen again, and again to no avail.

I have seen a still shot somewhere of the scene unlock, but no one seems to have been able to trigger it that I know of.

I'm wondering if anyone has done it in the past, but somehow the recent update broke the unlock function on this scene?

There is a related question here: Which characters unlock each scene?

  • 1
    Before people flag this as a duplicate, I have posted this separately due to the strange behavior of this particular scene. It is certainly a related question, but it is not unlocking with the ? bitizen recommended by the game itself! – David M Jan 14 '14 at 18:53
  • 1
    I think this is a bug yet to be fixed. Hopefully, the devs would straighten this out in the next update. It's highly unlikely that a whole community of internet users have not found a way to unlock the scene if it's not buggy. – Han Jan 15 '14 at 4:05
  • I agree with you. I was just curious to see if anyone was successful on an older build or something. – David M Jan 15 '14 at 12:55
  • possible duplicate of Which characters unlock each scene? – kotekzot Jan 15 '14 at 14:03
  • 1
    @kotekzot of course that is true. But, I'm trying to gather information about whether or not this has EVER worked for anyone. I wish to submit a tech support ticket to Disney and I'm gathering as much info as possible. – David M Jan 15 '14 at 14:38
4

As of the 1.3.0 update, the Snowtrooper now unlocks the Scoop of Hoth cutscene.

screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.