4

I just ruined my client's video settings somehow and my display shows "input not supported" when the client is running, which means I can't see anything. I tried to press ~ and type cvar_restart right after the video disappears, but it didn't work and I had to force-quit the game.

Is there a way to reset video settings without launching the game?

  • I still can't make the game work properly in fullscreen mode, so I'll play in maximized window instead for now. – user1306322 Jan 20 '14 at 12:42
4

You'll want to edit your Quake Live configuration file. This can be found in the following locations, depending on the version of Windows you're running:

  • Windows XP: %appdata%\id Software\quakelive\home\baseq3

  • Windows Vista or later: %userprofile%\AppData\LocalLow\id Software\quakelive\home\baseq3

Once you've opened this location, it's the qzconfig.cfg file you're after. In this file, search for the line r_mode. This will be set to a value between -2 and 27, depending on the resolutions available to the game.

Here is a list of r_mode values:

-2   Desktop resolution        16   1280x800
-1   Custom resolution         17   1280x1024
0    320x240                   18   1440x900
1    400x300                   19   1600x900
2    512x385                   20   1600x1000
3    640x360                   21   1680x1050
4    640x400                   22   1600x1200
5    640x480                   23   1920x1080
6    800x450                   24   1920x1200
7    852x480                   25   1920x1440
8    800x500                   26   2048x1536
9    800x600                   27   2560x1600
10   1024x640
11   1024x576
12   1024x768
13   1152x864
14   1280x720
15   1280x768

Simply change the value of r_mode to a resolution your monitor can support.

If you want to use a custom resolution, set r_mode to -1 and take a look at the following settings:

r_aspectratio  - aspect ratio setting
r_customheight - custom height (ie: 1080 in 1920x1080) 
r_customwidth  - custom width (ie: 1920 in 1920x1080)

In addition to the above, you can also set Quake Live to run in Window Mode by setting r_fullscreen to 0 (or 1 to set full screen).

  • It's worth noting that you can simply copypaste these relative paths into Windows Explorer path bar and it'll get you to your destination. – user1306322 Jan 20 '14 at 13:12
1

Things have changed since the provided answers from 2014.

Quake Live is now part of Steam, so the folder paths from the other answers no longer apply.

On Windows 10, the path to the Quake Live config files on Steam is:

"c:\Program Files (x86)\Steam\steamapps\common\Quake Live\[your user number]\baseq3\"


For screens with 2560 x 1440 resolution

If you happen to play in a "2k" screen, like me, I use an Acer XZ321QU (32") screen with a resolution of 2560 x 1440, note that Quake Live does not have this resolution in its menu. This means you have to manually set it up in the qzconfig.cfg file.

This is pretty easy based on the answers provided by @kalina and @user1306322 above.

This is how the settings in the qzconfig.cfg should look like:

seta r_mode "-1"
seta r_customwidth "2560"
seta r_customheight "1440"

Obviously, the values 2560 and 1440 can be anything else your monitor supports.

Note: You may get a small dialog box from Steam asking you if you'd like to use the config file from the cloud (old file) or the one you just edit locally. Upload the local one.

Hope this helps.

0

In the file

C:\Users\{your user account name}\AppData\LocalLow\id Software\quakelive\home\baseq3\qzconfig.cfg

change seta r_fullscreen "1" to seta r_fullscreen "0" and save. This will launch the client in windowed mode.

  • there's a special "native resolution" option which apparently fs the video up, so I dunno – user1306322 Jan 20 '14 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.