1

I am running a Bukkit (Spigot actually) MC server and I want to get custom player heads, as per here. This is all over the web, but I cannot get it working in my Server!

When I run the command that is needed /give playername 397:3 1 player:playername or /give playername 397 3 1 {SkullOwner:"playername"} it just returns

Too many arguments.
/give [-do] [-d] <target> <item[:data]> [amount]

What is the issue? If this would fit better on Stack Overflow or Server Fault, please migrate this.

2

The problem might be Commandbook. Try disabling it and try again.

  • How do I do this? Would just moving the plugin .jar out of the folder disable it or do I have to run a command in the server prompt? – RPiAwesomeness Jan 22 '14 at 19:48
  • You can just rename the plugin into something.disabled and restart the server. – Darakath Jan 22 '14 at 19:55
  • YAY! It worked! However, can I restart the server with CommandBook enabled and still have the head as it is? – RPiAwesomeness Jan 22 '14 at 20:03
  • Yes, I'm pretty sure it would work. – Darakath Jan 22 '14 at 20:25
  • Worked fine. Heads are up and CommandBook is going fine. – RPiAwesomeness Jan 23 '14 at 12:37
2

Try this

/give player minecraft:skull 1 3 {SkullOwner:"playername"}

  • Same error. Too many arguments. This is really very perturbing! – RPiAwesomeness Jan 22 '14 at 19:19
  • Huh really? It worked perfectly fine for me. What version are you using? – aman207 Jan 22 '14 at 19:21
  • CraftBukkit version git-Spigot-1257 (MC 1.7.2) (Implementing API version 1.7.2-R0.3-SNAPSHOT) Could this be a plugin conflict? I only have 5 small ones: Plugins (5): WarpPortals, NoSpawnChunks, ClearLag, WorldEdit, CommandBook – RPiAwesomeness Jan 22 '14 at 19:24
  • Command worked, I just had to disable CommandBook. It was a plugin conflict :D – RPiAwesomeness Jan 22 '14 at 20:03
  • Huh well that's good to know. Glad you got it figure out. – aman207 Jan 22 '14 at 23:48
2

I know the question is old, but I have the best solution. Without disabling any plugins, just type:

/bukkit:give player minecraft:skull 1 3 {SkullOwner:"playername"}

The "bukkit:" in front of the command tells the server it is the Minecraft give command, not CommandBook, or any other give command.

  • Interesting solution, thanks for this! I'll remember it for the future :D – RPiAwesomeness Mar 30 '15 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.