-5

I'm trying to install mods for Minecraft, and nothing seems to work. I am using Forge 1.7.2. When I install a mod and start the game, Minecraft works, but not the mods, and I don't know why. I know I am doing everything correctly but none of the mods are doing anything.

When I try to download any other mod, they dont work either; they do the same as the first, or the game crashes when I press play.

I have been trying for a while to get mods working, and I can just tell that I'm very close. I also know I'm putting the mods in the right folder.

closed as unclear what you're asking by aytimothy, GnomeSlice, galacticninja, 5pike, Mathias711 Jun 30 '15 at 14:43

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What version Forge/Minecraft are you using? What mods did you try to install? Please provide more information. – Darakath Jan 25 '14 at 15:21
  • i am using version 1.7.2 of forgeand i am trying to install the backpack mod – Neon_Toaster Jan 25 '14 at 15:23
  • are you trying to install the 1.7.2 version of the backback mod? what version of minecraft are you using? – Ender Jan 25 '14 at 15:51
  • This question is a mess, you start it by saying your forge wont work, then you say when you startup the game you only get 3 default mods, then you say the game crashes when you install a mod... your flat out contradicting yourself. We cannot read your mind, and your questions are a car wreck. please calm down and take the time to write out your request in a manner that is easier to understand so we can help you. – Ender Jan 25 '14 at 15:52
  • well sorry then – Neon_Toaster Jan 25 '14 at 16:41
5

Versioning is extremely important when working with Minecraft mods. You absolutely must have the version of the mod that will work with the version of Minecraft you are running. Currently there are very few mods that support v1.7.2. Most people will run an older version of Minecraft that supports the mods they want.

As an example, the Backpack mod is currently only working with Minecraft v1.6.2+ (that is, only the v1.6 subversions) and not any of the v1.7 subversions.

In order to use the mod, you will need to download and install the v1.6.4 version of Forge and the v1.6.2 version of the Backpack mod.

Not the answer you're looking for? Browse other questions tagged or ask your own question.