I am running around in circles trying to connect to my recently set-up Minecraft server. The Minecraft server is installed and running on my Ubuntu (12.04 LTS) machine. I have opened the port 25565 on my router without any problems and did a test using canyouseeme.org.

Test results:

port 25565 test

As you can see, the process (the server) is being detected and not blocked on port 25565.

Screenshot of server.properties:

enter image description here

server.log content after I tried to connect via external ip and then localhost:

2014-01-26 01:35:40 [INFO] Done (0.920s)! For help, type "help" or "?"
2014-01-26 01:40:08 [INFO] /*censored*:46013 lost connection
2014-01-26 01:40:19 [INFO] /*censored*:46022 lost connection
2014-01-26 01:41:34 [INFO] Disconnecting / Protocol error
2014-01-26 01:41:34 [INFO] / lost connection
2014-01-26 01:41:43 [INFO] Disconnecting / Protocol error
2014-01-26 01:41:43 [INFO] / lost connection
  • Connection to server is being refused both when added and using direct connect.
  • I am using the format global-ip:port when connecting but I've also tried just using the ip address.
  • The server and client are both running version 1.7.4.
  • It's a vanilla server.

I have searched high and low and tried everything I could find but alas still no luck. Could anyone please shed a light on what I am missing?

  • Can you connect to your server by localhost? Does your server log have some information on this?
    – Enoch
    Jan 25, 2014 at 23:25
  • @Darakath Added server.log contents. When I connect via localhost it gives me; Internal Exception: java.io.IOException: Connection reset by peer. By the sounds of it, it is implying that I changed something after I turned the server on but I'm pretty confident that I didn't.
    – C_B
    Jan 26, 2014 at 1:47
  • What version is the server and client?
    – Nathan C
    Jan 29, 2014 at 19:14
  • Is this a modded, vanilla, or bukkit server?
    – aman207
    Feb 1, 2014 at 5:08
  • @aman207 vanilla
    – C_B
    Feb 1, 2014 at 16:58

3 Answers 3


There are two possible reasons why you are getting the protocol error disconnects that I can think of.

  1. Your Minecraft Client and Minecraft Server are running different versions of the game. Check that those match, that you are not using a server.jar from 1.6 and a minecraft client of 1.7.4.

  2. You have a local firewall rule enabled that is not allowing you to connect properly.

  • I see, I have a suspicion it might be the first one. How do I update a the minecraft server on Ubuntu? Or will I need to start from scratch and download the new one?
    – C_B
    Feb 1, 2014 at 17:18
  • 1
    @CiaranBaselmans Just replace minecraft_server.jar with a new one found here
    – aman207
    Feb 2, 2014 at 5:49
  • I have updated the server and both the client and the server are running 1.7.4 but alas the connection is still being refused.
    – C_B
    Feb 2, 2014 at 22:49
  • 1
    try connecting to: "localhost" instead of the actual IP, I think you may have some firewalling issues still.
    – tremor
    Feb 3, 2014 at 4:23

Here are a few things to try:

  1. If you are running both the client and server on the same computer, connect using as the IP address (localhost), if you are running the server and client on your local home network, but on different machines, try connecting using the local IP address. If you do not get the connection refused error, you could have a problem with port forwarding. If you do get the error try the following.

  2. In your configuration you have the setting "online-mode=true", try setting this to false and connecting using the above methods. Normally this setting only causes problems for users who have not paid for the full version of the game and/or are not using the official launcher. If you are able to connect using this please clarify whether or not you have paid for the game and if you are using the official launcher or not (the launcher you get from minecraft.net)

  3. As mentioned above, check your firewall rules and maybe try connecting with your security program disabled (re enable it after this). If you are able to connect you will need to find out how to change your firewall/security program settings to allow java to recieve global traffic.

  4. Kick your computer, it won't help but people seem to do it anyways ;D

  5. You may be running multiple instances of the server. If so, you may want to kill (terminate) the java processes that are running them. If you're running the server and game on your computer, be sure not to kill your game's process.


If you are running the server on the same device that you are playing minecraft on use your ipv4 address to direct connect don't use the global ip or the localhost. also don't add the port at the end. If your friends are trying to connect use the global ip with the port at the end.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .