3

When playing Fallout 3, after about 5 minutes the mouse/keyboard stops responding to input, but the game is still running. If I disable the audio output using bEnableAudio=0 the game runs fine, albeit without audio.

The game is a Steam copy, and all updates are installed. I have also tried changing bUseThreadedAI=0 to 1, and added iNumHWThreads=2 but no luck. Installed codecs are K-Lite Codec Pack Mega 10.2.0

My PC specs are:

  • Acer V3-772G with Windows 8.1 64bit,
  • NVidia GTX 760M,
  • Realtek ALC282 Audio onboard,
  • 16GB ram,
  • Intel i7 4702MQ CPU

Has anyone else experienced the same or similar issues?

  • Well, it's obvious you don't get any sound; bEnableAudio=0 means you've disabled audio, after all. There's nothing you can do to get the sound working again, unless you either remove that, or make it bEnableAudio=1 instead. – Nolonar Jan 26 '14 at 22:43
  • 1
    If I set bEnableAudio=1 after about 5 min mouse and keyboard stop responding. I'm searching for solution where i can have sound and game working for more than 5 min. – Georgi Filipov Jan 27 '14 at 1:33
4

As always Microsoft in coalition with Bethesda make the best puzzles. My Windows 8.1 Pro N by default doesn't have Windows Media Player. After install of Windows Media Player the game is working perfectly.

Install instructions for Fallout 3 on Windows 8.1

  1. Install lates K-lite codecs
  2. Install Fallout 3 and lates updates
  3. Install Windows Live Client
  4. Install Windows Media Player
  5. Right click this file and open notepad: Documents\My Games\Fallout3\FALLOUT.INI
  6. Find (control+F) bUseThreadedAI=0
  7. Change to bUseThreadedAI=1
  8. Immediately after this line, ADD this new line: iNumHWThreads=2

Links: Windows Live Client, Windows Media Player

  • I would assume that whatever codecs the Windows Media Player runs under the covers are what fixed the issue. In any case nice job! – Robotnik Jan 28 '14 at 0:21
3

It appears you need to update your audio codecs, I found (this thread) which appears to describe the same problem.

The thread suggests that these codecs will fix the problem:

- K-Lite Mega Codec Pack 8.8.5

- K-Lite Codec Pack 6.3.5 (64bit)

You can get the latest version of the codecs here

Or older versions here

  • 1
    Links can and do change from time to time. Can you summarize the information located at that thread in case the link changes. Otherwise, great answer and welcome to Arqade. – David M Jan 27 '14 at 3:59
  • Thanks for the reply, but I forgot to mention that I'm using the latest K-Lite codecs, i will add version of my current codecs in question. As in the mentioned thread I have no sound in the main menu. I will try to change the settings of the codecs to see if I can make it work. – Georgi Filipov Jan 27 '14 at 9:07
  • It is possible that your codecs are in fact too recent, I've had a problem before where I tried to run an older game and I had to downgrade one for it to function. – DBS Jan 27 '14 at 11:14
  • @DavidM Thanks for the tips, answer updated with the key info from the thread. – DBS Jan 27 '14 at 11:24
  • @DBS Well done! Please enjoy our site! We look forward to more quality answers like this one! – David M Jan 27 '14 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.