4

At a point in the Thieve's Guild questline, Mercer Frey accompanies you to a dungeon. He has no dialogue other than one unimportant option, so you cannot ask him to stop following you. After several tries, I decided that the dungeon included in the quest is too hard to clear, so I'd like to level up before continuing. However, since Mercer won't stop following me, he continues to screw up my play style (as a sneak Illusion-type character), alerting people of my presence by opening doors that I've closed, standing in line-of-sight, etc.

He's very annoying. Without the aid of a mod, is there a console command or other way to tell him to buzz off while not breaking the quest when I chose to return to it?

  • 2
    How can second hand of thieves guild be so bad at sneaking xD ... Actually that would explain why they lost all the former glory in the first place. – Mentales Feb 1 '14 at 23:48
  • id recommend just lowering the difficulty and finishing the dungeon – l I Feb 2 '14 at 21:40
4

I guess you are on the "Speaking With Silence" quest.If it is the quest ID will be TG05 if not you can simply find your quest on the UESP and use its ID number.


You can reset the quest to it's initial stage ("meet Mercer Frey outside Snow Veil Sanctum") using

   setstage <quest id> <stage value>

in your case

   setstage TG05 0

or

   resetquest TG05 

This will reset your progress,quest items and followers linked to this quest/dungeon.


Use

  prid 00022651

to select Mercer,then

  setunconscious 1

to turn off his AI,he should just vegetate in the place you left him until you turn on his brain with

  setunconscious 0

Haven't tested this so I'm not sure what can go wrong.

As it turns out Mercer Frey will still teleport to your location(in attempt to follow you) if you go too far,however might be used in different scenario.


You can also try with set playerfollowercount to 0.Or using Disable then Enable on him,similar with Kill and Revive...But try them only as last resort since there is so much things that can go wrong with this commands(in regards to your quest).

  • I've tried using setstage, but it did not appear to do anything. I've managed to stick Mercer in a safe place using the setunconscious command, we'll see what happens when I unfreeze him! – Snailer Feb 2 '14 at 20:45
  • I had to unaccept this answer.. After playing a while with Mercer unconscious, I was sneaking around in a house and found him running in place.. on his back.. in the house. – Snailer Feb 2 '14 at 21:11
  • Lool for the bug,I guess he tried to follow you without his brain(make note,bad idea). But setstage should work,I have a lot of mods in Skyrim which brings a lot of bugs and I used this command to control my quests at least 15 times,it started to be very important feature for bugged quests. Go on the link I provided and check the bottom of the article for quest stages and codes,also check here uesp.net/wiki/Skyrim:Console for more info about the setstage.Try setting it to stage 0 or 1...or you could try ending the quest with 200 and see if you can then re-enable it with 10 or 0 – Mentales Feb 2 '14 at 21:35
  • I'm not sure if it was stopquest or resetquest, but one of those managed to end the entire quest, therefor stopping Mercer. I assume I can just use setstage to resume when I'm ready. If you edit your answer I'll accept it. – Snailer Feb 2 '14 at 23:53
  • Oh,It was "resetquest",and now I see why the "setstage 10" didn't work."resetquest" is equivalent to "setstage 0" which puts the initial quest in your journal.And "setstage 10" is "setstage 0" but completed.So when you entered the number 10 it was putting you on the same part of the quest you were already on,and you couldn't see the change. – Mentales Feb 3 '14 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.