I downloaded the Gothic II demo from here and installed it on my Dell Inspiron N5010 which is running Windows 7 Home Premium 64-bit. It seemed to go smoothly. However, when I double-click the shortcut nothing happens. I've tried:

  • restarting my computer
  • running the game directly from the exe
  • running it as administrator
  • running it in XP compatibility mode
  • switching off my AV (avast!)
  • uninstalling and reinstalling the demo
  • changing my res to 800x600, which did work for someone else

No go. I don't know if this is helpful to know, but the exe does not appear in my task manager's processes as it does for some other people who have had similar problems. Any ideas?

Edit: Actually the exe does appear briefly in processes before dying quietly.

  • Do you have Data Execution Prevention (DEP) enabled by any chance? If so, then try excluding the game executable in the DEP configuration.
    – DrFish
    Sep 16, 2011 at 8:56

4 Answers 4


Have you tried to update your video card drivers?

If so, try to reset your driver's settings (and disable all improvements).


You should install the so called "Report Version" but i don't know if the "Report Version" executable works with the demo version. Your can download here: http://www.worldofgothic.com/dl/?catid=25 or here: http://www.worldofgothic.de/dl/download_278.htm

If you have a Nvidia graphics card you may have to update your drivers. There is a known issue with Nvidia cards and Gothic 1/2:

Gothic 1/Gothic 2 –there is corruption and the game crashes. [621170]

Source: http://de.download.nvidia.com/Windows/196.21/196.21_Win7_WinVista_Desktop_Release_Notes.pdf

With the driver version 260.89 this bug was fixed. At first you should try out if updated graphic card driver will let the game start. Afterwards i would try to install the "Report Version". Good luck!

  • Thanks for your helpful response! OpenDNS blocks your first link for some reason, but your second one is ok. I've downloaded and tried to run version (I don't have the NOTR expansion), but when I try to browse to the correct directory the "ok" button remains greyed out. It remains this way no matter what folder I browse to, including the one where gothic2.exe is located. What gives? Feb 5, 2011 at 8:27
  • Well, thats probable because the "Report Version" is NOT able to patch the demo version. As i wrote i was not sure if you can apply the "Report Version" patch. Sorry, but i'm out of ideas now :(
    – Joe Scylla
    Feb 17, 2011 at 11:14

What if you right-click and try to change the compatibility mode? As I recall, you can set up the compatibility as far back as Windows 98 (or maybe 95). Hope that helps.


I had played Gothic 2 on win 7, but on proffessional and 32-bits, and it went very smooth. Didn't have to do anything with sys modes, and so. When I will find it, I will try to run it on Win 7 prof 64-bit (as it is my current sys), and try to give You some hints.

Still I seen people that had installed VirtualBox and winXP on it just to run old games, You could also give a try to that method if you really want to play, or You have more than one old game to play, and a spare win XP.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .