3

Recently I've been experiencing weird behaviors while playing League. My ping stays around a normal 80-90ms. Occasionally everything will stop moving then a few seconds later everything will happen all at once. All the while ping is still where it was before.

Other times I won't see particles appear from my Champions at all. I won't always see Vayne's Silver Bolt stacks on enemies. And as Draven I won't see the landing spots of my Spinning Axes, or see them going through the air either (which is incredibly frustrating as his damage/kit revolves around keeping them up).

Is this something on my end, or is it the fault or the servers? Whichever one it is, is it something that I can fix?

3
  • This is a known issue that occurs when textures don't load properly during the loading screen. This can also sometimes result in wrong textures (e.g. caster minion attacks are Flash icons), sometimes textures in wrong colours (e.g. all particles are black), and sometimes transparent/non-loaded textures (e.g. some particles are invisible). I'd write this as an answer but I'm in too much of a rush to cite right now; I might flesh it out later. :P
    – Schism
    Commented Feb 5, 2014 at 17:19
  • 1
    Oh really curious about the answer aswell... I hate it when minions are throwing flash icons around
    – Jutschge
    Commented Feb 5, 2014 at 17:36
  • What you can do to fix this is do a quick restart of the game. That always seems to help me. It's just a workaround though, riot should implement a /reloadui command or something like that.
    – Sir Ksilem
    Commented Feb 18, 2014 at 10:37

1 Answer 1

1

The two issues are unrelated. The issue with particles are simply an issue with your game loading, as Schism said in his comment. I've had a lot of these issues myself, although never quite to the degree mentioned here. I see lower quality spell and item icons, and blue blocks in place of particles. If you have a fast enough computer I recommend restarting the game itself. First, you want to alert your team by saying something along the lines of "BRB, need to restart to fix a bug." Then you need to quit the game itself. You have two options to do this. The first is to quit by opening the menu (Escape) and clicking the 'Exit Game' button. This will display a prompt that warns you about the potential penalties of quitting. Click 'Quit Game' after the 5 second wait period, and the game will close. The other option is to pull up your task manager or force quit on Mac. This would be Control+Alt+Delete on Windows, or ⌘+Alt+⎋ (Command+Alt+Escape), on Mac. The simple act of summoning either of these from within the game will cause the game to 'crash.' From there, the LoLClient should bring itself up, and display a "Reconnect" button. Click this and you're done. Keep in mind, both methods of closing the game incur the same penalties, should you not reconnect before the game finishes. Also, no matter what the cause, you should always immediately move your champion once the game re-loads, in order to prevent being kicked by the LeaverBuster system. If your game can load within a few seconds, then it should be worth it to do this, however, depending on the glitch and your system, you may want to consider just dealing with it for the duration of the game.

As for the ping and disconnect issue, I've been having similar issues. The solution I've found is that my ISP is in fact dropping chunks of data packets. Because the game has not received any of it's packets in return, the system cannot update the ping. The game stops as it tries to reconnect, and will more often than not finish and re-establish connection before the "Attempting to Reconnect" icon appears. Call your Internet Service Provider, and have them double check the equipment they gave you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .