4

I used to play games easily on my laptop, I bought a new laptop (a Lenovo E540) and I installed Windows 8.1, which is the same operating system as I had on the old one, and I ran through all of the system updates for drivers and DirectX.

I installed the same games on my new laptop (ex: Assassin's Creed IV - Black Flag) but a strange weird error displayed "Application Was Unable To Start Correctly (0xc00007b)" as follows:

enter image description here

How can I resolve this issue?

migrated from superuser.com Feb 7 '14 at 8:08

This question came from our site for computer enthusiasts and power users.

  • 3
    According to Microsoft, 0xC000007B is an error code with the meaning STATUS_INVALID_IMAGE_FORMAT. There are a couple of reasons why this error can appear, but for a game, this usually means something is wrong with the executable file. Have you tried re-installing the game? – Michael Madsen Feb 7 '14 at 8:36
  • 1
    yes, even I got a different copy of the game, but the issue still the same??? – Ya Basha Feb 7 '14 at 15:12
4

The only solution that worked for me was to reinstall Windows 8.1.

After deep investigation, I found that one of the DLLs for DirectX was corrupted.

I tried to update DirectX but it keep informing me that I had the latest version with no errors.

  • Maybe you could uninstall and reinstall DirectX? – Joe the Person Feb 11 '14 at 13:42
  • this is not possible, there is no way to uninstall directx – Ya Basha Feb 11 '14 at 13:53
  • Not even the redist? – Joe the Person Feb 11 '14 at 14:26
3

The error message 0xC000007B typically indicates that the .NET Framework that the game was built with is not installed. A quick google search indicates that Black Flag requires the framework version 4.5.1. This should be installed with the game unless it was cancelled for some reason.

.NET Framwork 4.5.1 specifies the following minimum system requirements:

Supported Operating System

Windows 7 Service Pack 1, Windows 8, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows Vista Service Pack 2 Hardware Requirements: •1 GHz or faster processor •512 MB of RAM •850 MB of available hard disk space (x86) •2 GB of available hard disk space (x64)

  • 1
    4.5.1 is installed by default on Windows 8.1 it's literally not possible not to have it installed – Ramhound Feb 10 '14 at 23:34
1

take the xinput1_3.dll in C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher and put it in c:\windows\system32 and it's all right.

  • 2
    Please take a moment to explain why this fixes things, and where you learned this. – Shadur Feb 18 '14 at 11:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.