1

My control is set to left-click. But I've noticed with my Asus X55C laptop touchpad, when I left click it doesn't punch/mine/hit 9/10 times. This is only with Minecraft and it's not just one version or mod because it's on all of the versions modded and unmodded.

  • 3
    try and rebind it to a keypress or plug in a mouse, touchpads are notoriously bad at handling game input. – Rapitor Feb 7 '14 at 21:36
  • left click needs to be held to break blocks, or rebind it to a key – ratchet freak Feb 7 '14 at 22:36
  • Your laptop may not register clicks, even when you leave your finger on the touchpad, as a held click. It would probably be best to do as @Rapitor suggests and do a keybind. That was the only solution while playing on my macbook. – zero298 Feb 13 '15 at 22:44
3

It's a Palmcheck, I would imagine. I have had the same problem. Except I couldn't even move my head.

If you have synaptics touchpad driver (most laptops do)

  • Open system tray, click the Synaptics icon, and click pointing device properties.
  • Select the device settings tab.
  • Select your tracpad device, and press reset devices.
    • Do not close out of this window, but try breaking blocks again at this point. If this did not work, then it's probably palmcheck.
  • Select your device again, and click settings. Go to Palmcheck enhanced, and slide palmcheck all the way down, to off. If you don't have synaptics, consider referring to this article.
0

I have an Asus laptop as well, and one thing I notice that helps in minecraft with clicking with the touchpad is double-tapping and holding on the second tap.

0

You can do a little test to see if it is a part of Minecraft that handles the controls or if it is just your laptop acting weird. First set the control that is "spazzing out" to a key on the keyboard, go to options, controls, click on the control which is activated when mouse button one is clicked. (called mine or slash ore something like that). Set it to a mouse button. Press this button ingame and check if it still does that.

So now you are left with 2 options: ether it still does that or it does not.. lets call theme option 1 and option 2 for the sake of easily navigating trough this answer.

Back up your .minecraft folder and lose minecraft

Option 1. if it still does it just set it back to the mouse button and navigate to your .minecraft folder in roaming. type %appdata% in the windows explorer. then go to this path:

.minecraft\libraries\org\lwjgl\

Delete all the files in that folder, then connect to the internet. Launch Minecraft.

Option 2. If that does not work the only thing I can come up with getting another input device (mouse) and connecting it to make it work.

You might still try the LWJGL thing from option 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.