0

I'm creating my own mod pack (just adding mods I like to one big mod pack to play with friends) and now I have the following mods added: mod list. The problem is, after adding RailCraft mod, when I start the server - everything works fine, server is running (I host server on my local host - the same machine I run client). But, when I start client and try to create new world, connect to server or load early created worlds client just stops responding. When I connect to my server I get player connected, then, after some amount of time, SocketTimeoutException and player disconnected. The main issue also is that I don't get any crash reports since client is not responding and I have to kill the process via task manager. Also, I created new mod pack with only several mods - BuildCraft, ThermalExpansion, NEI and, of course, RailCraft - everything worked fine: singleplayer loaded, world generated, all mods worked just great. So, I suggest, there is some conflict with one of the other mods. Can someone give me a hint which mod can cause the problem? And how can I fix this?

P.S. Minecraft version is 1.6.4.

// EDITS

After reading this topic at RailCraft forum I tried to remove GregTech mod and everything worked fine. So, obviously, there is some conflict betwenn GregTech and RailCraft. Any suggestions what exactly can cause the issue and is it possible to make those two mods work together or should I wait next mod update with the fix?

closed as off-topic by Tim S., greg-449, galacticninja, walrus helmet, FoxMcCloud Jun 29 at 20:44

  • This question does not appear to be about videogames or videogame consoles within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

0

After some googling around and updating RailCraft to newer version!!! I changed my JVM arguments for client and server:

-Xms2048M -Xmx4096M -XX:PermSize=256m -XX:MaxPermSize=512m

The issue was in permgen memory - it was to low (by default 128m), so the client was freezing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.