I have a problem with running Morrowind Overhaul - Sounds And Graphics on my fresh Morrowind installation (through Steam).

I deactivated Steam Overlay, even deactivated ingame MGE, but when I press on "New" to start a new game in the loading screen it crashes to desktop.

I also checked all options and I can't find issues. The problem itself is reproduceable as it happens everytime I try.

Until this point everything seems to load fine.

What can I do to make me lose once again a time of youth in Morrowind?

If you need any more information, please let me know.

Windows 8
AMD FX-8150
GTX 670
2560x1080p resolution (one monitor)

Without MGSO it runs perfectly. So maybe one component of this mod causes an issue?

  • Pretty specific question, probably hard to answer. Off course you could try the basic things "reboot", "verify integrity of game cache", "reinstall". Even on a clean install things might go wrong. Also, it is an old game, are you sure it has windows 8 support? – Madmenyo Feb 16 '14 at 8:17
  • Yessir! Ive already tried that. Yes, without MGSO it runs on Windows 8 perfectly. I'll add that above. I also see that I'm not alone with that problem, but in forums they never tell how they solve it. :D – Trollwut Feb 16 '14 at 10:38
  • Have you tried to run it in windowed mode, at least for the character creation? – ayckoster Aug 17 '14 at 18:32
  • On a search for nostalgia, I'd suggest only using MGE. It increases the view distance to be more like modern games while still having a 'vanilla' experience. – Mazura Apr 19 '15 at 17:01

It seems like Morrowind cannot play the cutscene in the beginning of the game for some reason. You could open MGSO settings, go to misc tab, then open Morrowind Code Patch and see if Morrowind code patch has this enabled:

enter image description here

If you have it disabled, enable it and vice versa to see if it helps anything. I couldn't find any other settings that could affect the video.

Then of course, try running in windowed mode and compatibility mode should be XP SP3 for Morrowind.exe.

If that didn't help, check if you have any other software that let you limit your FPS and/or add overlays to games. If you have MSI Afterburner and Rivatuner for example (Rivatuner lets you cap the FPS of the game and add an overlay to it to show your temps etc.) turn it off and see if it works.


I did some searching for you and some people have succes with installing MGSO in XP SP3 compatibility mode. Completely remove the mod and install it again.

  • Ah, that's a solution if you can't install MGSO, but this mod installs very nicely on my system. But thanks for your effort! – Trollwut Feb 16 '14 at 14:08
  • Did you try it? Installing it in compatibility mode might install it slightly different then a regular windows 8 install. Like registry entries and who knows what crap windows 8 does to your install. It helped some people that had problems running MGSO on windows 7 and 8. – Madmenyo Feb 17 '14 at 7:09
  • Yes, I tried it before posting my comment just to be sure. :) – Trollwut Feb 17 '14 at 7:51



Game version: 1.6.1820

MWSE version:

Other mods: a lot, but the game works perfect if MWSE is not on

Error messages: none, just a straight up game crash upon trying to start a new game

OS: Win7

edit: I solved it through including Morrowind.exe in the Data Execution Prevention whitelist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.