I bought Magicka via Steam this evening, and just installed it now. It demanded to repair my XNA install, so I let it.

I'm trying to run it, but it's just quitting as soon as it opens.

Any ideas?

  • Have you tried uninstalling and reinstalling the XNA, then? – badp Jan 31 '11 at 11:39
  • @badp Yes (with no change), though not with a reboot in between. I was hoping some cough magic solution might be available so I didn't have to kill my session while I had some other stuff open. I'll see whether it works in the morning. – Margaret Jan 31 '11 at 11:42
  • @badp Actually, changed my mind and did so now. Discovered there were two versions installed (3.0 and 3.1). Uninstalled them both, rebooted, and then installed 3.1. No change in behaviour. It loads magicka.exe for a few seconds then the process disappears. – Margaret Jan 31 '11 at 11:56
  • Someone is saying that updating their .NET framework helped. So you might want to try that. – mordi2k Jan 31 '11 at 12:08
  • Remember that usually those versions do not replace or conflict with each other, so you want to reinstall 3.0 too! – badp Jan 31 '11 at 13:08

If it asked to repair the XNA framework on your first start it most likely means that it was already installed. The other dependencies should be the .NET framework, either 3.0 or 3.5, and DirectX. I would try to install all of that manually and see if that fixes it.

Just to be sure also update your graphics card drivers.

Download links:


Ah! The magic that seems to have finally made a difference was manually setting the system to the graphics driver. (My system has Optimus tech. It works well, when it works, but a lot of programs are missing from its application list.

On my machine: NVIDIA Control Panel, "Manage 3D settings" from the treeview on the left, and then go to the "Program Settings" tab and click "Add" to get an 'open file' box. Locate Magicka in your file directory structure, and then change the preferred graphics processor in the dropdown on the NVIDIA control panel. Then don't forget to click "Apply"! It doesn't auto-save.

  • 1
    Magicka does not support intel integrated graphics, that could be the reason. – Mad Scientist Feb 1 '11 at 14:24
  • I'm having the same problem, have you fixed it? if you did, how? I can see the comment about the application list.. but i have no idea how to go about doing that... – user7522 Mar 3 '11 at 20:16
  • @Andy Edited the post with details of how it works for me. – Margaret Mar 3 '11 at 21:45

It had this exact problem with fresh Windows 7 install. The game seemed to boot up fine, smoothly progressing throught slash screens but the game crashed as soon as the book came into view.

The way I solved it was to install the A.R.E.S. demo. They both use XNA and A.R.E.S. doesn't have the XNA bug in the installer.

The only other game I had installed at the time was Left 4 Dead 2. But I'm pretty sure the L4D2 didn't effect Magicka.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.