I have two monitors, and I often use the "extend" mode to work on both simultaneously as a large desktop. When playing games full-screen only one monitor is used, and that's fine.

However, I would like to use the other monitor to still work and display some other application windows. The problem is that with many games, moving the mouse to the edge of the primary monitor can cause it to move to the other monitor, and thus leave the game window. This is very troubling when using games where I need to move the mouse to the edge of the monitor in order to scroll the view. In these cases I am forced to disable the secondary monitor for the duration of my gameplay.

Is there any way to "trap" the mouse inside the game window, i.e. to prevent it from moving to another monitor as long as the game is in focus, so that only alt-tabbing away will allow the mouse to move there?

  • Very good question indeed. I'd like to hear a solution myself.
    – DrFish
    Commented Feb 1, 2011 at 15:06

10 Answers 10


Here are some more mouse-trap applications, like CSMMT which Shaun's answer mentioned, that trap your mouse cursor in one screen of a multi-monitor setup:

I can't vouch for any of these, but you can try them out. You can also search for more with keywords "multi monitor trap mouse" or similar.


Short answer:

  • New games: Run in fullscreen mode.
  • Old games: Use CSMMT.

Long Answer:

The best way to accomplish your goal in newer games is to run the game in fullscreen mode. This is a simple configuration option within the game and it will require no new software.

Take World of Warcraft (WoW), for example. Running it in fullscreen mode would be annoying to me. If I wanted to look something up, I would have to alt-tab to the desktop. That would get annoying, so instead I disable fullscreen mode (choosing windowed mode instead) and just make the window the size of the screen (which, in the case of WoW, is actually a third option: Windowed (maximized)). Same large-screen effect, but then I can mouse over to the second desktop to look things up. My FPS suffers slightly, but my video card is so beefy that it doesn't matter.

Now, take StarCraft 2 (SC2). Occasionally, I want to look something up. Much more importantly, though, I was to slam my cursor against the side of the screen so I start scrolling over to see events nearby. Having my mouse wander off onto my other desktop simply doesn't work out for me in this situation. So, I play SC2 in fullscreen mode and it's not an issue. My mouse is trapped and I don't have to worry about it wandering away.

Now, the above solutions only work for new games that have been made to be aware of multiple monitors. Older games did not know how to deal with situations where you went off the side of the screen and as a result. There are some pretty cheesy workarounds for this (unplug or disable the 2nd display while playing the game, orient your monitors at diagonals from each other). However, you might want to try CSMMT. It was made specifically to help trap your mouse for older programs where side-scrolling is a necessity.

  • Naturally, I'm talking about games that already exhibited such a behavior (not trapping the mouse), otherwise I wouldn't have asked. Specifically, Civilization V is quite new and still doesn't trap the mouse.
    – Oak
    Commented Feb 1, 2011 at 15:43
  • I figured that was likely the case, hence why I mentioned CSMMT rather than stopping at "Use the in-game setting". However, I also like to make my answers complete. :)
    – Shaun
    Commented Feb 1, 2011 at 15:44
  • Also, CMMT looks perfect for this role - unfortunately, the site seems out-of-date, the "buy" link doesn't even work.
    – Oak
    Commented Feb 1, 2011 at 15:48
  • Ew. The trial download still works, but that would prove to be annoying quickly. :( I'd suggest contacting their support. If that doesn't work and it's truly abandonware, then my answer may be useless to you. :(
    – Shaun
    Commented Feb 1, 2011 at 15:54

For Civ 5, this should have been fixed in the patch that was released at the end of October 2010. In my version of the game, there is a setting in the option to "Bind" the mouse to the game window {Never | Full-Screen Only | Always}.

Where did you purchase the game? If you purchased on Steam like I did, you should be automatically updated to the latest patch level unless you specifically disabled that feature. For other vendors, check with their support to see where you can download the updates.

  • Thank you, this indeed solved my immediate problem! I would still like to see some solution that would also work for games who do not support this themselves, though.
    – Oak
    Commented Feb 1, 2011 at 17:19

So let me get this straight...

The task is really simple: if you have a full-screen program open (essentially a game), lock the mouse to the main monitor. If the game is closed or minimized, unlock the mouse automatically.

At the time of writing, none of the free programs listed here do this, and the only program which claims that can do it costs $10.

So I wrote my own:

  • Free and open-source
  • Tiny, 8KB EXE
  • No installation, no configuration, no dependencies - start and forget it!
  • Activates when and only when it's needed, so should not get in your way

Source code: https://github.com/CyberShadow/AutoMouseLock
Compiled .exe: https://files.thecybershadow.net/AutoMouseLock/


I use a free program called Dual-Display Mouse Manager. It's standalone, which means it does not need to be installed, and is maintained on sourceforge: http://ddmm.sourceforge.net/

I only mention it because the programs mentioned above all look sketchier and/or costlier.


I had this issue with Mass Effect 2 and The Elder Scrolls V: Skyrim.

What seemed to be causing the issue was that my old monitor ran at a lower resolution (1680 x 1050) and when I bought my new Full HD monitor (1920 x 1080) the games were running at the old monitors lower resolution.

I noticed that when running games in full screen, my old monitor (set up as extended desktop) would shift to the right as if it was being pushed aside by the new monitor.

When I changed the resolution of the games up to my new monitors native resolution the problem was fixed. No need for mouse managing programs.

In short, check that the game you're playing is set to the native resolution of the monitor that it's being played on. Hope that helps!


I have tried multiple tools, including the ones Wikwocket suggested, but they either didn't work well or had too much unwanted functionality (some which couldn't be turned off).

On the other hand, a Google search brought me to DDMM(Dual Display Mouse Manager). Meets my needs (mouse-trapping, not the alt-tabbing part from this question) and until now I didn't notice any downsides.

You can also configure the app to only let the mouse move to the seconds screen when Ctrl is pressed

  • 1
    Your link just comes back to this page; I suspect that's not what you were wanting.
    – Frank
    Commented Apr 18, 2013 at 13:56

Actual Multiple Monitors contains this feature. It's cost about $30.. but it is the best software for multiple monitors.


If you have DisplayFusion, you can use it to do this.

You can set up "Monitor Profiles", so I set one up with my main monitor enabled and the other monitor disabled. I just switch to that profile, play the game, then switch back when finished. You can use hotkeys to make this easier.


I didn't have the problem with gaming, it just started happening when I got a new monitor today. All of a sudden, my Windows 7 thought I had an extended monitor.

I googled the problem: apparently all you have to do to fix my problem is hold down the Windows button on your keyboard, press 'p' while still holding the other, and you can choose how many monitors you want to use, going through the options just by pressing 'p.'

Hope this makes it easier for anyone.

Source: Logic As Art (original link is now broken)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .