5

This is not the fast weapon switch setting. How do I disable this menu when I use the number keys to switch. Seriously, it showed up out of nowhere, I changed no settings, and it's really irritating when trying to deal with a spy. I restarted my game and no luck.

EDIT: It does not happen if I am healing someone and switch weapons if that helps. Is this a bug?enter image description here

  • 1
    Looks kind of like a console (as in Xbox or PS3/4) quick-select menu. Do you have a controller plugged into your PC? it's possible TF2 detected it – Robotnik Feb 25 '14 at 10:47
  • 4
    If you found the answer, you should add it as an answer, instead of editing the question :) – Robotnik Feb 25 '14 at 10:53
1

From OP:

I figured it out, it was because I have a wired xbox360 controller plugged in. It like takes control of some of the ways the game works. Unplugging the controller took the game back to normal. It also screws up the engineer menu and combines the build and destroy tools, this is how I found out what was wrong. It was telling me left trigger to destroy my sentry.

  • 1
    If the developer console is enabled, it's also possible to undo this by running exec undo360controller.cfg in the dev console. It can also be reenabled via the dev console by running exec 360controllercfg on Windows/OSX or exec 360controller-linux.cfg on Linux. – Powerlord Oct 17 '17 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.