1

I have been following this tutorial to make my own TF2 server. And have gotten to video Sechs (six), and I have tried to connect to my own server by going to the server browser in TF2, but it says there are no servers on [my] current network. Everything has worked exactly as AVeryPatientPlayer said it should, except I cannot connect to my own server.

I have:

  • Port Forwarded 27015 (I don't need to DMZ, since I have just one router; but this should affect me connecting to it on LAN)(Forcing the server to start on 25565 which has worked in the past for my MC server didn't change a thing)
  • Done everything as the guy in the tutorial says I should.
  • Made sure that I am using my ethernet IPv4 for everything, making sure not to use my wireless- even turning it off
  • Added the sample server.cfg that is shown at the bottom of the tutorial page and changed a few values, such as server name and RCOn password.
  • Added a custom mapcycle.txt

I have not:

  • Installed any mods aside from SouceMod and MetaMod as in the tutorial
  • Been able to find it on TF2's server browser "LAN" tab.

What first hinted to this problem for me (and why I decided to test connecting to it) is that every time during the tutorials, AVPP goes to his server "console" tab it says something about connected and the public IP. I looked at mine and it was just blank. It did respond when I typed in the commands "Meta version" as done in the tutorial.

Could someone help me? I would really like to get this server working so my friends and I can play together.

  • My server has now started crashing on Startup. As soon as it is done loading, it briefly shows the settings page, then crashes and vanishes. I have tried validating the download and it is all correct, according to SteamCMD. – Greatmar2 Mar 3 '14 at 15:05
  • Here is part of the log file: (version "2123087") L 03/03/2014 - 17:10:29: server_cvar: "sv_tags" "Rotating voteformap,alltalk,mvm,norespawntime" L 03/03/2014 - 17:10:29: server_cvar: "sv_tags" "Rotating voteformap,alltalk,mvm,norespawntime" L 03/03/2014 - 17:10:29: Sending CMsgGameServerMatchmakingStatus (state=ServerMatchmakingState_NOT_PARTICIPATING) L 03/03/2014 - 17:10:30: server_cvar: "sm_nextmap" "cp_dustbowl" L 03/03/2014 - 17:10:30: Arqade Meta Loaded 0 plugins (1 already loaded) L 03/03/2014 - 17:10:30: server_message: "quit" L 03/03/2014 - 17:10:30: Log file closed – Greatmar2 Mar 3 '14 at 15:11
  • I believe such questions are off-topic here. – Austin Mohr Mar 4 '14 at 16:27
  • @AustinMohr I'm not sure how setting up a TF2 server would be off-topic; that plays right to our expertise. – Frank Mar 4 '14 at 18:25
  • Thank you @Frank. I just updated the server, with the new TF2 update today, and it is still crashing on startup. I'll try redownload the whole thing on the weekend. Note: In my previous comment, the log said "Meta" not "Arquade meta" – Greatmar2 Mar 6 '14 at 19:33
0

I am unsure what the cause of the "unable to connect" problem was, but I have updated my TF2 dedicated server files and now the console does show text once it has started and I, and my friends from their own houses, can connect. I do know, however, the reason that the server was crashing on startup. I was attempting to start the server on a MVM map, none of which are shown on the in-game level voting.

Thank you to those who have read and devoted some of your time to try help me solve this problem, even though it was not a problem we could have solved.

0

Attempt to use the command connect localhost:27015 in the console. This should directly connect you to your server at your local IP. If you have a different port, replace the 27015 with whatever port you are using.

  • Thanks, but this has been resolved some time ago. Reading the answer I posted, it was because the server was crashing on startup - since I had it on an MvM map without the required player cap. – Greatmar2 Dec 15 '15 at 5:55
  • @Greatmar2 Oh, sorry. I just joined StackExcange a week ago, so I don't really know where to check stuff. Sorry about that. – SpecialBomb Dec 15 '15 at 18:25
  • Haha, no worries. Thanks for the effort, anyways. :) – Greatmar2 Dec 17 '15 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.