I have the most recent version of Java, but I cant download Minecraft Forge 1.7.2 for some reason. (I have a Macbook Pro) Whenever I try to download it it says "The Java JAR file "forge-1.7.2-" could not be launched. Check the Console for possible error messages." What does that mean and how can I download it!?

When I put it in the Terminal it said:

Exception in thread "main" java.lang.NoClassDefFoundError: forge-1/7/2-10/12/0/1034-universal/jar
Caused by: java.lang.ClassNotFoundException: forge-1.7.2-
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

And when I downloaded the other thing in the link, It gave me a Folder with a bunch of stuff in it I have no idea what to do with... So, Theres some more info.

  • If an answer helped you, accept it by clicking the grey checkmark next to it rather than editing the question.
    – kotekzot
    Mar 8, 2014 at 20:12
  • 4
    I'm voting to close this question as off-topic because it is about tech support for modded Minecraft. We only provide tech support for vanilla Minecraft.
    – Frank
    Apr 18, 2019 at 22:15

2 Answers 2


Try using the installer. Forge 1.7.2

  • I just tried your link, I downloaded it. It said it works... But, I cant find the Forge 1.7.2 in the Minecraft version selection.
    – Torkoal1
    Mar 3, 2014 at 23:42
  • Did you already play 1.7.2 without mods (vanilla)?
    – Duncan
    Mar 5, 2014 at 14:00
  • Actually, I thought I played 1.7.2, I guess I didn't... sorry about that false info. My game says there WAS no 1.7.2... So, I didn't play 1.7.2. I played 1.7.4 and 1.7.5 but not 1.7.2
    – Torkoal1
    Mar 7, 2014 at 6:29
  • Thank you, I just figured out how to get 1.7.2 working and I re-tried your installer and it worked! Thanks!!!
    – Torkoal1
    Mar 8, 2014 at 20:07
  • @Torkoal1 If my answer helped, please feel free to set this answer as accepted by clicking the check icon on the left.
    – Duncan
    Mar 9, 2014 at 21:27

First , make sure you have the most up to date java runtime. It can be found on the oracle website here: http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

To run the jar in a console. Open up finder search your applications for terminal. Open terminal put the jar in your user directory. Type into terminal: java -jar jarName.jar Push enter. It should run the jar in the open terminal. You will be able to see errors and copy, paste them into your question, update the question. You should be able to type the first few letters of your jar file name and then press tab to auto complete it. If that doesn't work rename the jar name to something shorter so you will be able to type it easier.

Not the answer you're looking for? Browse other questions tagged .