3

This has happened to a number of my favourite games now and its infuriating!

Is there a way I can make my GForce graphics card compatible with DirectDraw to run AOE 2 on my new windows 8.1 machine?

the game wont run without that compatibility...

3
  • Can you share exact error message? (screenshot can work as well)... edit: ugh, I have not noticed how old this thread is, sorry ;p – PTwr Jul 4 '14 at 8:39
  • @PTwr It is totally fine I will get that screen shot for you I am still struggling to get this game working... Windows 8 is the bane of my existence – ThunderToes Jul 14 '14 at 8:36
  • 1
    Related: gaming.stackexchange.com/questions/191038/… – user101016 Sep 9 '15 at 22:50
5

I would recommend locating the age2.exe file, right clicking on it and going to properties. Under the compatibility tab, set it to Windows XP Service pack 3 and see if that resolves the issue. Running as administrator I've found to sometimes help as well.

If that doesn't work, Age of Empire 2 HD is available on Steam, which is fully compatible with Windows 8.1 (I played it just the other day on 8.1 and it worked flawlessly).

1
  • 2
    I'm sorry about that illiterate comment btw... what I tried to say was is there no way of making the game work with the CD I bought instead of Buying the game again? – ThunderToes Jun 4 '14 at 10:43
1

I know that this question is old however no actual answer to the core problem. So there is a way to patch "Direct draw error" or what is known as "could not initialize graphics system" with AoE2Tools. I had the same problem with a DVI cable and the following guide helped me.

Step 1: Go to the official download page of AoE2Tools Then scroll down to the assets section then download "AoE2Tools.X.X.X.X.exe" e.g. aoe2tools download setup

Step 2: Once installed, press the "SCAN" button in the middle of the Launcher (then wait 10 - 15 seconds until the "2- Start" button is no longer grayed out) Scan on launcher

Step 3: Now Press "2- Start" button and click yes to a hotfix alert, then AoE2Tools UI should come up then click "Fix UserPatch" and confirm yes to apply the patch. fix userpatch

Step 4: Right click "AoE2Tools Shield Logo" to the top left hand side then press "Voobly Medkit" aoe2tools and Voobly Medkit

Now select "Fix Couldn't Display Or DirectDraw Display Error" and hit apply fix direct draw error

Finally click Download Fix and that's it. Just wait for it to install and once it's done the game should run without that nasty error anymore.

The Original author of this guide and finding (credits to GregStein):

https://ageofnotes.com/resolve-issues/how-to-fix-could-not-initialize-graphics-system-for-age-of-empires-2/

2
  • 1
    For this to be considered a proper answer, you need to relay the appropriate information from the link to your answer. – Joachim Oct 5 '19 at 14:35
  • 1
    It's done brother! I have written more detailed steps which I followed to fix the issue. – MrJack Mcfreder Oct 5 '19 at 17:38
0

The issue is a graphics card problem where your card is too powerful for the game.

Try any/all of the following to fix the problem:

  • Uninstall the game completely then reinstall (only worth trying if the game ran at least once before you experienced the problem)

  • Update your graphics card drivers

  • Downgrade your graphics card drivers

  • Disable your graphics card within Device Manager then restart Windows (remember to re-enable after you have finished playing)

-1

You should try running it in compatibility mode - to do this:

  • Right click on the empires2 exe
  • Go to Properties, and open the Compatibility tab
  • Tick the box "run this program in compatibility mode for" and scroll down to windows 8 (or a compatible OS).
-1

Just right-click and select "troubleshoot compatibility". Test the program. If it works, save it. That worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.