3

I'm not as young as I used to be. The days of my finding slamming the A button on my game pad as fast as I possibly can and then some and finding it fun are behind me. So, while I appreciate the use of the mechanic in The Stick of Truth, I'd be much more fond of it if most of them weren't, well, nigh impossible.

Seriously, even a simple one like the toilet minigame, routinely takes me 3-5 attempts, and I have to literally put down my game pad and frantically jab at the A button with two fingers. And I've been literally stuck in the alien abduction sequence, unable to advance past the second probe, for about half an hour now. This is insane and unreasonable. I don't have a game pad with a 'turbo' feature, but god do I wish I did right now. Adjusting the in game difficulty slider doesn't seem to affect this. Is there anything I can do to increase the failure tolerance of these QTE's? Or am I doomed to destroy my gamepad?

  • You don't have to press the button but just rub over the button left and right real fast, I remember doing that when I was too young to fast push the buttons. – Lyrion Mar 6 '14 at 7:56
  • @Lyrion doesn't work with my gamepad. – LessPop_MoreFizz Mar 6 '14 at 9:07
  • Why not? What kind of buttons does your gamepad have then? Because it works with the flatted out buttons like ps3, and the rounded down buttons like the xbox. Also you could try instead ofrubbing your thumb, rubbing with a spoon since it is rounded down more. – Lyrion Mar 6 '14 at 9:14
  • @LessPop_MoreFizz I'm about the same age, and we can still mash buttons with the best of them Fizz, you just have to beleive! Beleive in the Mega Man! – Ender Mar 6 '14 at 12:19
  • get hyped up on sugar and mountain dew. that'll work. But unless there's a config file hidden somewhere (I haven't found one) there is no way to change timing. – Rapitor Mar 6 '14 at 16:58
3

So, after doing some more research, I'm pretty sure there's no way to do this.

Fortunately, for most parts of the game (read: using special attacks in combat), the QTE's/Timing events are either fairly easy, or fairly inconsequential. The game just isn't hard enough that blocking every attack is the difference between winning and losing, and the difficulty slider is there if you really do have trouble.

Which leaves QTE's like the one that you're confronted with during the aforementioned night one Alien Abduction sequence. For which, at least for me, there was only solution which I could make work, after several hours of trying (and, I think, possibly damage to one of my two gamepads - something is seriously mistuned, and I suspect it is at least partly a bug, based on the lack of complaints about the issue at the level of severity I'm describing from console players). Either way, I settled on a solution because it worked, and because this is a single player game, and because my pride was already completely demolished. I cheated.

Specifically, I used Autohotkey and created a script that mashes the button required a dozen times instantly. I hit the macro once, and it passed the QTE check. You can literally follow the steps from the AHK Tutorial, and simply, instead of typing in #space::Run www.google.com on the blank line, simply paste in

^!s::Send sssssssssssssssssssssssss

Then, whenever you press Control+alt+s, it'll act as though you've mashed the button. (S is the games keyboard equivalent to 'a' on the gamepad for these QTE's. Should you need a different button, just replace the s's with d's or a's or whatever.

Note: To use this macro, you'll need to unplug your gamepad momentarily so that the game reverts to keyboard controls, but the game switches between control schemes very gracefully and on the fly, so there should be no need to worry about restarting it or other hoops to jump through that might make this solution inconvenient.

This won't help with precision based QTE's, but for the truly egregious button mashers, this should solve the problem.

  • Haha, this is indeed super cheating :p. Anyway i'm playing on the pc too, and I haven't had much trouble with it. The last anal probe was indeed somewhat hard, but I mashed through it :p – Lyrion Mar 7 '14 at 7:27
  • You can bind an autohotkey macro to a controller-button... – BlueRaja - Danny Pflughoeft Mar 7 '14 at 17:22
  • @BlueRaja-DannyPflughoeft you can! However, getting AHK to output controller buttons rapidly is... much more complicated (if it's possible at all. I admit I tried to figure it out and after realizing that a solution if it existed was buried in a mess of poorly documented forum threads, my eyes glazed over.), and the game doesn't accept keyboard input for QTEs while a game pad is plugged in. – LessPop_MoreFizz Mar 7 '14 at 17:31
  • I don't understand, the binds for inputs and outputs are the same. Do Joy1-Joy32 not work? – BlueRaja - Danny Pflughoeft Mar 7 '14 at 17:43
0

On the PS3, I found an easy way to do it. Get a pen, and sort of act like you're trying to scribble on the X button. It saved me lots of effort.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.