5

I bought a Windows 7 machine and went to install Civilization IV on it. It told me the program had "known problems". If I continue it begins the startup process but eventually fails. What do I need to do to get it working?

2
  • I run CivIV on my Win7 machine all the time and have never had the least trouble. Is there something else unusual about your computer? Feb 4, 2011 at 1:16
  • Brand new Dell. Windows 7 Home Premium. Feb 4, 2011 at 18:16

3 Answers 3

3

OK I got this working and it seems you need to do two things.

  1. Update DirectX. The one from the Civ 4 disk may work, or this: http://www.microsoft.com/downloads/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en
  2. Upgrade the game to version 1.74, which can be downloaded. Firaxis appears to no longer support this patch, but it is available from Gamespy: http://planetcivilization.gamespy.com/View.php?view=Patches.Detail&id=35

The DirectX upgrade may or may not have been necessary. It certainly doesn't work without the patch upgrade. You don't need any of the Windows 7 compatibility modes.

1

Did you try just ignoring that message and continuing on with the install? I've run Civ 4 on my Windows 7 machine and haven't experienced any issues.

2
  • This should work
    – Viper_Sb
    Feb 3, 2011 at 19:53
  • It does eventually fail to load. I've edited to reflect that. Feb 3, 2011 at 21:29
-1

Updating my graphic card driver solved this problem for me.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .