I launch Civlization V from steam and the launcher appears, it gives me the option of Direct X 9, Direct X 10 & 11 or Windows 8 Touch Enabled Mode. I wish to run it in DX11 so I select that, the window then disappears then nothing happens. How can I launch it in DX11 mode?


I've just spent about 30 minutes seeking this solution but I finally figured it out. I know how frustrating it can be to find straightforward answers to problems and I don't want the time I spent figuring this out to be wasted. If I can help one person it is worth it. Anyways here is how I fixed it.

All you have to do is install this official version of DirectX from Microsoft. I don't know why but this solved my problem immediately.

Here is the link: http://www.microsoft.com/en-us/download/details.aspx?id=35

Have fun and enjoy

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.