Till yesterday I was playing AOE3 in multiplayer LAN with my brother ( LAN through WIFI ) and it was perfectly smooth.

Today I installed The Asian Dynasties expansion pack on both the systems and I don't see any hosted games detected by this expansion pack. I tried connecting to a specific IP directly, but it is of no use. I am not able to play on LAN with Asian Dynasties installed.

What might be the problem?

  • It works fine for me most of the time, but I have experienced this problem before. Doing the standard disconnecting and reconnecting and/or restarting the computer fixes it though. – Ullallulloo Feb 6 '11 at 0:17
  • It did not work for me even once. The hosted game is not visible in the other computer in the LAN. What might be the problem? – Vivek Feb 9 '11 at 16:21

I fixed it. I used Hamachi and it resolved my problem.

I downloaded AOE3Loader from here and then I created a new network using Hamachi. I gave the NetworkID and Password of this Hamachi network to my friends so they could join the network. I then opened AOE3Loader to run the game. It will show the Hamachi IP instead of local IP, and then it works.

  • May I suggest you explain a little more what you did to solve the problem? It may help other people in the future. – juan Feb 10 '11 at 14:51
  • I downloaded AOE3Loader from here and then I created new network using Hamachi. Now I gave the NetworID and Password of Hamachi to my friends to join the network. Then opened AOEloader.exe to run the game. It will show Hamachi IP instead of local IP. And thus it worked – Vivek Feb 10 '11 at 17:03

try disabling windows firewall I also had same problem make sure you have disabled windows fire wall and other virus scanners in all the systems you have connected with.


I had a similar issue turns out that installing VirtualBox creates another network device that the game was trying to use by default. I used Device Manager to uninstall the device and now it works. Hope this is useful to someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.