I downloaded NEI for Minecraft 1.6.4. For some reason, it will not stop acting like Recipe mode! I don't mean "I cant change it," because I can. But no matter what I do, it seems stuck on Recipe Mode! I tried deleting and then changing the configs, I have tried absolutely everything I can think of. I just want to use the enchant thingy! Can anyone help?

  • Dupe, perhaps: gaming.stackexchange.com/questions/158709/nei-recipe-mode-only
    – Frank
    Commented Mar 17, 2014 at 13:30
  • 1
    So you set the lockmode=-1, and changed it to cheat mode, but when you click on an item in NEI to cheat it in, it doesn't work?
    – Unionhawk
    Commented Mar 17, 2014 at 13:35
  • Without clarification, we can't really help you; I cannot reproduce this at all.
    – Unionhawk
    Commented Mar 17, 2014 at 23:11
  • As an extra note: if you play on a multiplayer server and are not op I think it will lock you to recipe mode for that server. Or something along those lines. It's been quite some time since I looked at that.
    – Arperum
    Commented Oct 23, 2015 at 8:06

2 Answers 2


It will be disabled in the config file.

  1. Go to the config folder probably %appdata%/.minecraft/config
  2. Then find NEI.cfg and open it (notepad can do it)
  3. Edit the line that says lockmode=0 to lockmode=-1

This should allow you to go in to cheat mode. this config is mainly there for people like me who cant help them self s for spawning lost items in.

  • that doesn't work bro. when i do this, and restart my game, log in, and try to get my survival kit, it only shows recipes again (yes i went into the config and changed lockmode to 1 and nothing happened.)
    – user82560
    Commented Jul 15, 2014 at 5:34
  • @19palkia The answer says to use -1, negative one. Did you try that? Commented Jul 15, 2014 at 10:35

I suspect that if this is a mod pack then the settings will be in user mode but the main setting are set in global,

Open the NEI setting by pressing E then click options in the bottom left then click inventory. you will get a screen like this.

NEI Menu

in the top right there will be a button you need to make sure this says global before making any changes to the settings so that they apply to the game as a whole.

Hope this helps. this is the case with most mod packs.

(Note: If the "W" boxes are ticked, they will override global settings, which can be confusing if you were unaware an override was active, so be sure to check for this as well.)

  • +1. In my case, I I had a W on the settings that was overriding the global settings. Removing the W, or changing the world setting worked
    – Mathter
    Commented Jun 7, 2017 at 1:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .