2

I have a Mac Pro and I would like to idle on TF2. The problem is that there is no toolbar so I can't get out of TF2 unless I disconnect from the server I'm on and I quit TF2. I would like to know how to get the border/toolbar on the window.

2
  • 2
    I don't have much experience on macs, but can't you just command+tab to the desktop like on windows? Commented Mar 22, 2014 at 2:22
  • Oh, wow! I didn't remember to do that. Works! Though it didn't show the little switching animation, so i guess valve tried to prevent idling and switching to different windows. Commented Mar 22, 2014 at 2:27

2 Answers 2

2

To get TF2 in a window:

  1. From the main menu, click Options and then the Video tab.
  2. Change the Display mode setting to Run in a window.
  3. You will probably also want to set the Resolution (which will now control the window size) to something smaller than your actual screen size so that the window fits nicely.
  4. Click OK or Apply.

As noted in comments, you can also use Command-Tab to switch away and leave TF2 running in the background, instead of using windowed mode.

(Information that might be useful context for curious readers from other platforms: There are about three different ways of implementing full-screen on Mac OS X, and a lot of games use an older one that defaults to leaving Command-Tab non-functional. Luckily, TF2 does support it.)

1

Add -windowed -noborder to steam startup options.

But don't try to idle. it doesn't work anymore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .