0

I am playing Diablo 3: ROS and having FPS issues while my girlfriend's laptop runs the game like a dream.

My setup:

  • Intel i7, 4770k 3.5gHz,
  • 16GB RAM,
  • 2 Nvidia GeForce GTX760s (SLI),
  • 750 Watt power supply,
  • and the game is installed on my SSD.

I had no problems a week ago, and now I get between 7-25 FPS. The lag is unplayable, and before anyone mentions it could be network lag I'm hardwired, my girlfriend's laptop is wireless and not even the slightest hint of lag on her computer.

Also I'd like to make note that the FPS results are the same at both maxed out graphic and minimum graphic options in game.

Any advice helps!

  • Did you update your drivers recently? Maybe that's what causes the lags? – Nolonar Mar 27 '14 at 3:11
  • all drivers are up to date – user72860 Mar 27 '14 at 3:55
  • Untick the "reflection" box in the video setting and try again and try with Vertical sync enabled and disabled to see. Btw I have the same spec as you and the game is running smoothly. If that does not do the trick try to disable the SLI, I had some driver issue with diablo and the SLI enabled with the latest version of the drivers. – WizLiz Mar 27 '14 at 7:25
  • enabling vsync helped a little... reflections were never on, when I disabled the sli I saw more lag spikes – user72860 Mar 27 '14 at 17:35
  • 2
    @user72860 you should post that as an answer and accept it. – kotekzot Mar 30 '14 at 11:19
1

I had a similar issue, fps decreased and it was difficult to even move the cursor. Cursory googling lead to this forum post.

The advice given was to set Window's display font setting to the default value of 100%. I was at 125% and changing it back to 100% helped my situation. The fps returned to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.