2

I'm playing with the new ARM stuff, and it's nice. But I tried to load up my research center, and it says it's closed. Some Googling quickly showed me that this happens in Sandbox mode. But my save is definitely a Career mode save. What gives? I need my R&D.

Edit: I managed to overwrite my old persistent save (why does KSP overwrite...) but I have a quicksave! It's just bugged beyond use. I have an in-flight mission but none of the parts or game mechanics (e.g. gravity) are working correctly.

8
  • 1
    1.) Are you sure your save is a Career mode save? 2.) Is this, by any chance, a pre-0.21 save?
    – user98085
    Apr 8, 2014 at 21:48
  • Yes, it is definitely Career, and no. It's 0.22, which I also played some 0.23, and then just now some 0.23.5.
    – DeadMG
    Apr 8, 2014 at 21:49
  • Alright, mind uploading your persistent.sfs to, say, pastebin? Probably some corrupted Scenario data or similar.
    – user98085
    Apr 8, 2014 at 21:50
  • Here it is. I saw some advice about loading an old quicksave, which I did, except the quicksave is in the middle of a flight and the ship is bugged beyond usability- e.g. moving at 0m/s without being pulled in by gravity, parts don't respond to commands, EVA crashes the game, tracking center doesn't recognize the flight, etc.
    – DeadMG
    Apr 8, 2014 at 21:53
  • Hm, loads perfectly fine for me. Can't find any inconsistencies either. Back up the save folder, reinstall KSP and see if that works.
    – user98085
    Apr 8, 2014 at 22:06

1 Answer 1

1

Turns out the game can fix itself if you give it some time- through time warp. Eventually, the game "notices" that it's started and suddenly gravity and all the parts work again, so I simply loaded the quicksave and tried time warp. After a few seconds at 10k it started functioning again, so I did indeed retrieve my save.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .