5

I've just built a steamos machine and have HL2-Deathmatch running perfectly. Unfortunately some of the smallest fonts are too small to see on the TV (highlighted in red): enter image description here enter image description here

How do I increase the size of these particular fonts?

**I changed every font size in ClientScheme.res (before I posted the question). Didn't solve the problem as far as I could tell... **

update It appears that the steampipe update may explain why editing clientscheme.res isn't working: http://steamcommunity.com/app/320/discussions/0/828937546133516432/

9
  • 1
    Related: How do I adjust Steam chat font sizes?, although it might answer your question
    – Robotnik
    Commented Apr 9, 2014 at 8:54
  • 1
    That seems to be related to steam UI. I have no problem with fonts in the UI part. It's just in HL-2 Deathmatch that some of the fonts are too small to read... Commented Apr 9, 2014 at 10:07
  • nevertheless its a start, valve wrote both, perhaps HL has a similar setup to steam in regards to fonts?
    – Robotnik
    Commented Apr 9, 2014 at 11:03
  • 1
    I agree it's a start...i've been looking through files galore. Was hoping for a simple solution. :) Commented Apr 9, 2014 at 11:05
  • 1
    I would have suggested that you lock (as if in NTFS) that file to external writing, as I have for a question relating changing Steam fonts. However I do not have experience in Linux and it would mean that ClientScheme is not only in charge of font size but that is is being overwritten every time you start the game. Commented Apr 12, 2014 at 21:05

4 Answers 4

0

This is an easy one :)

Open this page: http://hl2dm-maps.com/www/hl2/HUDTutorial.pdf and read it, which lasts less then 15 minutes (maybe you'll find other interesting edits on you hl dm)

However the most interesting part for you should be step 7 (and the introduction which announces the tools).

PLEASE do a backup of the files you alter, unless you want to reinstall the game in case you mess something up ;)

You fetch your ClientScheme.res and edit the values of "tall" for example for QuickInfo to 48.

Some machines have had problems using fontsizes which were not spcified in the fontfile. So these following values should work fine: (20, 22, 24, 26, 28, 32) And these should be big enough for your purposes: 36, 40, 44, 48, 54, 60, 66, 72, 80, 88, 96

One last thing: be careful with these files. Don't change the values too fast, as you do not know how the machine responds.

3
  • I have already tried editing the tall values of ClientScheme.res (as mentioned in the question)--several times now. Hasn't worked yet, so can't accept as an answer yet. Commented Apr 15, 2014 at 7:12
  • I'm sorry, i dont know how I did not see this :S May you write down what happens if you alter this file? As this tutorial helped a friend of mine half a year ago :) I guess its a resolution caused problem Commented Apr 15, 2014 at 7:19
  • See the edit. Nothing happens when the file is edited. I believe this may be a steampipe issue. Commented Apr 15, 2014 at 13:03
0

This will show you everything you need to know about modifying your HUD for HL2D: http://steamcommunity.com/sharedfiles/filedetails/?id=161652635

This article shows you how to modify the HUD using pretty simple CSS. You will find a README located here that shows you exactly what you need to change. how to change it and where to put it in your Steam folder.

4
  • 2
    Explain how that addresses the issue at hand in the answer.
    – user37332
    Commented Apr 14, 2014 at 20:52
  • Hi @ChaseC - we tend to avoid link-only answers as they may go missing, becoming useless. Could you summarise the steps presented in the walkthrough?
    – Robotnik
    Commented Apr 15, 2014 at 8:17
  • @Robotnik Yeah sure, sorry about that.
    – FoxMcCloud
    Commented Apr 15, 2014 at 13:05
  • I believe that this won't work because of steampipe. (Plus I've edited res files left and right, but no change)... Commented Apr 16, 2014 at 10:43
0

Installing mscorefonts has made the smallest fonts slightly more readable:

sudo apt-get install ttf-mscorefonts-installer

There are various guides on enabling Debian sources in SteamOS e.g., http://wp.xin.at/archives/1593

As for increasing the size of the fonts (making them much larger than standard), this appears to be a SteamPipe issue (which isn't solved with this solution).

tl;dr installing mscorefonts makes fonts slightly larger

4
  • Could you say, swap the offending font with an even larger-print one? As in, actually rename the font file
    – Robotnik
    Commented Apr 16, 2014 at 10:40
  • Possibly. But messing around with fonts like that is liable to mess up the system... Commented Apr 16, 2014 at 10:41
  • Hmm. I dunno about that. If a font couldn't be found it would just revert to the standard system font, plus so long as you keep a backup of the original file you can always revert if necessary. Up to you of course, its your system :-)
    – Robotnik
    Commented Apr 16, 2014 at 10:58
  • I had a look. I don't see how changing to another font is going to increase its size. mscorefonts are ttf files and the size is specified in the res files for HL2-DM. Changing ttf files is at best going to result in a different font of the same size? At least the fonts are readable now (with my solution) which is much better than it was. :) Commented Apr 16, 2014 at 11:01
-2

You can try changing the resolution, making either a windowed or a smaller resolution when in full screen will make the hud (icons, visible text, etc) appear bigger and more readable. If not, send a support ticket to Valve.

1
  • 3
    I'm playing on the TV. I'm playing on 720 so changing the resolution is not an option (it's smaller at 1080). Also this is in Steamos..so windowed mode also isn't an option. Commented Apr 12, 2014 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .