12

Whenever I run Dota 2, Steam shows me this UAC dialog:
UAC Steam Program Files (x86)\Steam\bin\steamservice.exe /installscript steamapps\common\dota 2 beta\runasadmin.vdf 570

If I click No, the game launches. If I click Yes, I see the following and then the game launches.
Performing First Time Setup | Installing (Step 1 of 1)

It's just an annoyance, but how can I prevent this from happening?

I've tried reinstalling both Steam and the game.

  • 1
    @Mkalafut Eh, that's not too inspiring. I kind of appreciate UAC. – Louis Apr 10 '14 at 18:35
  • 2
    Also, try running Steam and the game as an administrator. – Mkalafut Apr 10 '14 at 18:56
  • 7
    You know you can take a screenshot without using a camera... – Keavon Apr 10 '14 at 20:42
  • 5
    @Keavon I'm not aware of a way to take a screenshot of the secure desktop. – Louis Apr 16 '14 at 19:42
  • 1
    @Louis Sorry, I didn't realize you normally aren't able to do that, although I did find a guide. I don't expect anyone to do follow that, though. – Keavon Apr 16 '14 at 21:47
17
+150

Identify the "steam app" number (I think DOTA2 is 570)

Find the installscript.vdf file in the game's install folder. Open it with a text editor You will see lines like this:

{...} InstallScript" { "Run Process" { "DirectX" {...}

For every "run process" item like DirectX highlighted above, add a new dword parameter in the registry and set it to 1 in the proper registry node. For Dota2, the app node is:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Valve\Steam\Apps\570

If you using a 32-bit OS, omit Wow6432Node.

You can examine sibling game nodes for more confirmation, but I think once it all runs, steam also adds a dword named "Installed" with a value of 1.

Rarely, an installscript.vdf has a typo (like "DircetX"). I think you need to copy the typo in the registry entry.

This file may be rewritten when steam updates a game. Clearing the contents is a temporary fix.

  • I wanted to try this first, to counter the downvote, but I simply don't have that noce (@Valve) – Louis Apr 10 '14 at 21:29
  • search for "steam". lists the registry entries: support.steampowered.com/kb_article.php?ref=9609-OBMP-2526 – horatio Apr 10 '14 at 21:31
  • 1
    @Louis: Running first time setup should create that node. If you create it by hand (my DOTA2 install just has "directx" = 1) it will prevent the script from running. – Ben Jackson Apr 19 '14 at 6:59
1
  • Go to the directory where Dota 2 is installed in your Steam Library.
  • Open installscript.vdf with Notepad or any other text editor
  • Replace the contents with:
"InstallScript"
{

}
  • Save the file and close Notepad.
  • Set installscript.vdf to be read only via the file's properties.

This way Steam should never bug you again.

0

I'd like to add an answer for the strange cases when someones encounters that first time setup problem and no solution they can find on the Web works.

What to do Uninstall the previous version of the appropriate Visual C++ Redistributable so that you game's specific redistributable can install and then tell the Steam client that it (the specific redist) finished correctly.

I have provided a full explanation on Steam discussions.

Summary of the explanation

There are cases when the "First time setup" and consequently the UAC window are caused by (read carefully, because it's unbelievable to me) a more recent version of the Visual C++ redistributable... Yes, you read it correctly.

Suppose you have already installed a game that required a Visual C++ redistributable package (version 10.0.40219 in my case). In case a game that requires an older version (10.0.30319 in my case) of the package tries to perform its setup, the VC redist installer will fail.

Yes, it will fail instead of reporting a success like one (meaning "I") would think. The programmers of the VC redist packages apparently consider it a failure when trying to install x.y.z while x.y.t, with t > z, is already there.

In my case, the game wasn't Dota 2, it was Ace Combat Assault Horizon in its PC version. Setting values in the registry didn't help. Running Steam as admin didn't help either. Nothing did. Except uninstalling the more recent version of the redistributable package.

Reinstall version 10.0.40219 of the distributable. Applications built with the latest version of Visual Studio 2010 SP1 require it.

Finally, run Windows update. Your game may use a version 10.0.30319 redistributable that predates security fixes addressing it (example).

-3

Just remove this file.. it worked for me

enter image description here

then open 570_install.vdf as text, then delete all text inside of it then paste this...

"InstallScript"
{

}

save it.. DONE !

protected by Community May 12 '15 at 19:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.