6

I'm trying to run a dedicated Q3 1.32b linux-i386 Nov 14 2002 from a headless Ubuntu 12.04.

Server is not seen in server list. When trying to connect explicitly by address:port from from client machine i get:

Awaiting Connection... 3..5..10... 70...n.

and nothing happens next.

This is how i execute:

quake3@iceberg:~/.q3a/baseq3$ /usr/local/games/quake3/q3ded +set sv_punkbuster 0 +set net_ip 10.0.1.5 +set net_port 27960  +exec ./maprotation.cfg 
Q3 1.32b linux-i386 Nov 14 2002
----- FS_Startup -----
Current search path:
/home/quake3/.q3a/baseq3/pak8.pk3 (9 files)
/home/quake3/.q3a/baseq3/pak7.pk3 (4 files)
/home/quake3/.q3a/baseq3/pak6.pk3 (64 files)
/home/quake3/.q3a/baseq3/pak5.pk3 (7 files)
/home/quake3/.q3a/baseq3/pak4.pk3 (272 files)
/home/quake3/.q3a/baseq3/pak3.pk3 (4 files)
/home/quake3/.q3a/baseq3/pak2.pk3 (148 files)
/home/quake3/.q3a/baseq3/pak1.pk3 (26 files)
/home/quake3/.q3a/baseq3/pak0.pk3 (3539 files)
/home/quake3/.q3a/baseq3
/home/quake3/.q3a/baseq3/baseq3
/usr/local/games/quake3/q3ded/baseq3

----------------------
4073 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
--- Common Initialization Complete ---
Opening IP socket: 10.0.1.5:27960
Hostname: iceberg.gate.kahovka
Alias: iceberg
IP: 127.0.1.1
Started tty console (use +set ttycon 0 to disable)
^3PunkBuster Server: PunkBuster Server (v0.993 | A0 C0.0) **DISABLED**
execing ./maprotation.cfg

You may have noticed that q3ded runs from it's special user. Running from root does not affect the problem. I started suspecting some network issue. So i did a checkup:

entropy@iceberg:~$ sudo netstat -alp --numeric-ports | grep 27960
udp    0     0 10.0.1.5:27960          0.0.0.0:*      9521/q3ded

A check from the client machine:

tim@thinkpad ~$ sudo nmap -sU 10.0.1.5 -p 27960
. . . 
27960/udp open|filtered quake3

I allowed all incoming and outgoing UDP traffic in iptables, but nothing changed.

Here is my main config: pastebin.com/wefnEpR6

My maprotation: pastebin.com/UFj2M0DY

Configured Q3 according to http://it.rcmd.org/networks/q3_install/q3_linux_server_howto.php

What can be the problem with this setup? I'm doomed, any help will be greatly appreciated!

  • 2
    A couple of things - your command line doesn't set dedicated to 1, maybe try that? Also, from what I recall of Q3 servers, they don't fully start up until a map loads. In the example configs, they run "vstr m1" at the end to kick off the maprotation. Your maprotation seems to be missing that. Perhaps one of those will help... – agent86 Apr 18 '14 at 15:19
  • 2
    Hmm, I may be off on the use of "vstr" in my previous comment, so that might not work. You might try (from the console) "map <mapname>" to get it to load a map, and see if the server responds to that with some additional messages. I don't see it picking a map and loading it according to your log file. – agent86 Apr 18 '14 at 15:27
  • Hi! It seems working now when i manually exec map q3dm17 from the server console. But it does not work with a "+exec maprotation.cfg" in the command line. The config executes itself fine, but no map started. I tried adding the advised "vstr m1" in the end of maprotation.cfg, but it still doesn't kick off. Any advice here? – qugu Apr 18 '14 at 17:28
  • 2
    You can add +map q3dm17 to the command line to make it launch that map automatically, or you can add the map q3dm17 command to any of the config files you're exec'ing. I don't think the maprotation.cfg actually starts the maprotation right now. You'd need to run the m1 alias in order to kick it off. Nothing in the game engine is going to do it for you. – agent86 Apr 18 '14 at 18:15
  • @agent86, when i load the server with maprotation config with vstr 1 at the end, and then run just m1 and press enter at the server console, the variable looks like echoed: m1 "m1" is:"map q3tourney3; set nextmap vstr m2^7" default:"map q3tourney3; set nextmap vstr m2^7" although the map in-game does not change. Is there any specific command needed? – qugu Apr 20 '14 at 10:52
3

Quake servers don't tend to actually fully start up until a map has loaded. None of your config or command line options are loading a map, so the server partially starts but won't allow a client to connect.

You've got several options.

Your maprotation config specifies a m1 alias that actually starts the map rotation, so you might just want to put that in some config file somewhere (after the maprotation is loaded, so that the alias is defined). This is probably the optimal solution.

You can also specify the map to load at startup with the command line argument +map (mapname). This will cause a map to load regardless of what is speified in the config files.

You could put a map (mapname) command somewhere in one of your configuration files. It doesn't really matter specifically where, since all config files are in the same language.

Alternatively, you can use the map (mapname) console command to start a map interactively after the server has started.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.