2

So, my computer's been having problems running Warframe. I run Warframe at the max possible low settings, and intermittently between games my computer would tell me I was running low on memory.

Some basic specs, I have an i5 that runs at 1.8Ghz, and 6gb of RAM, 2gb of dedicated VRam on a Nvidia 720M. Now, I thought that the problem must have been not having enough memory, so I bought a new memory module, so that I now have 12gb of RAM, 2gb of dedicated VRam.

I'm still getting the same problem. My computer is running hot all the time, even with additional RAM, RAM that I thought would help alleviate the problem of running the game.

I'm not sure if it's just me, but how would I get "more memory" for the game itself? I've noticed in Task Manager that even when running Warframe, it only takes up 4-5gb of memory, still leaving me with plenty of leftover memory, yet my computer insists it is running low on memory. I have tried setting priority, and that does nothing as well.

  • How big is your swap file? – BadSnowflake May 3 '14 at 17:07
  • I can't find a reference but I get this when gaming all the time. I always have plenty of spare memory and I found something that says that windows 8.1 has a problem that it erroneously displays this error message. I'd assume it is lying. – Chris May 3 '14 at 17:55
2

The message you're getting is about the video card memory. How much system RAM you have doesn't matter.

It's caused by two factors - Warframe uses a lot of video RAM and Windows is acting like a spoiled child.

For reference - I, too, have a video card with 2GBs of RAM (and a whopping 16GB of RAM as I also run virtual machines when I'm not gaming), and I get the same screen in Warframe and some other games. This is despite the fact that the system works well during games. In other words - Windows is throwing a fit.

There's a workaround, however. You can set Warframe (or Steam, if you're running the game through Steam) to disable Windows Visual Styles when running the game (right-click on the Warframe / Steam shortcut, go to the Compatibility tab and check the appropriate box). This should prevent the nagging Windows warning from appearing.

  • Dude, thank you so much. I've been struggling with this issue for such a long time, it's nice to get an answer that actually fixed that warning. – senpai Oct 16 '14 at 14:54
  • @memescientist I'm happy you like it. Personally I don't consider the workaround an actual fix - there's no real reason to turn of visual styles, it's just that Windows is being a crybaby... ;) – Shaamaan Oct 16 '14 at 15:28
  • Right, but it helps since I run WF at fullscreen, and I hate having to be interrupted by Windows politely telling me I'm running out of memory. – senpai Oct 16 '14 at 16:16
  • @memescientist Of course - it's just that a real fix (IMHO) should be the ability to turn off the nagging screen once and for all. – Shaamaan Oct 17 '14 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.