I'm trying to play an old school DOS Game I got using the DOSBOX DOS emulator, but the problem I have is that the mouse jumps all over the screen and does not allow me to have a good control. The game is Cannon Fodder, which need to have mouse input. So I'm thinking it is problem of conversion from USB mouse to the serial driver which the emulator uses. I already tried to lower the sensitivity using the emulator and to lower it using windows settings.

Anyone have any suggestions on how to resolve this?

  • DId a little research on this. Have you tried a PS/2 mouse, or can you do that?
    – DrFish
    Commented Feb 14, 2011 at 16:06
  • only have usb input Commented Feb 14, 2011 at 18:48

4 Answers 4


Not 100% sure this is the problem, but autolock often causes mouse issues in DOSBox. So try setting it to the opposite of whatever it currently is:

  • In your dosbox.conf file, look for a line setting autolock=false and remove the line (or change the false to true).
  • Or, if no line with autolock exists, add one with autolock=false.
  • 4
    i was able to fix it looks like game created it own config file called. dosboxCannonFodder.conf so i had to modify that file. i set sensitivity=1 Commented Feb 14, 2011 at 19:10
  • 1
    Setting autolock to false solved my issues with mouse in Dosbox. If you still need the mouse locked to the window (eg when playing shooter games), you can press Ctrl+F10 to manually lock the mouse to the window (works for me) or switch to full screen.
    – Martin
    Commented Feb 7, 2018 at 17:48

If you are trying to run dosbox in a virtualbox Ubuntu host, I had the same issue and it was driving me crazy. The mouse would just get stuck in a corner and wouldn't move except to the other corners. Here's the solution I found:

Make a text file and put this in it:


Save it on your desktop or somewhere else, right click on it and put a check where it say "allow to execute as application". Run the file and the mouse issue will be fixed.

  • 2
    Thanks, this was the solution for my mouse problem with the "Tex Murphy Martian Memorandum" version that comes with GoG. Commented Dec 27, 2016 at 21:04

I know that the original poster has already resolved their issue, but for everyone else hitting this from Google: for me this was an issue with VirtualBox's mouse integration. To fix it, disable your virtual machine's mouse integration by right clicking on the mouse icon in the bottom right-hand corner (second icon from the right).

After this, the mouse should respond to the sensitivity setting in DOSBox.


For anyone running Windows 10 who didn't have luck with the existing suggestions, using the DOSBox SVN-Daum menu option "Video/Driver/Restart DOSBox with DirectX Driver Only" worked for me. I've also added autolock=false to the config and turned off scaling, but I'm not sure if they had any effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .