2

I had a look at multiplayer in Dark Souls 2 and now every time I start the game it starts up in multiplayer mode. I want to go back to single player only. Is there a way to do this in game or by editing a configuration file?

Invasions aren't the problem; it's the visual noise created by the chalk messages, summon signs and blood stains. Ruins the mood for me.

  • 1
    Disable your internet connection? :P That seems to be the way Dark Souls is... – Keavon Apr 27 '14 at 5:52
  • Join the Way of the Blue covenent if youre having trouble with invaders – eyeofthehawks May 31 '14 at 13:44
1

There's no single player / multiplayer switch in Dark Souls 2 whatsoever.
Provided you have an internet connection working, you will only be able to play multiplayer.
In order to be totally offline you need to either starts the game in offline mode (if you can, on steam) or disconnect internet when the game started.

If you don't want to totally disable all the multiplayer aspects but just mitigate the risk of invasion you don't have to worry much in the beginning because there aren't any pvp area right at the start and the risk of being invaded is very low. You can also burn human effigies (as opposed to use it) to prevent invasions.

| improve this answer | |
  • 2
    Also, DON'T turn off your internet connection while in game with a loaded character, do it only in the main menu or before starting the game. Cutting off the internet connection during online play too often could result in the character being banned from online play for good. – Kodama Apr 27 '14 at 10:43
4

If you're playing on PC, you can simply block the game's executable from accessing the Internet with your firewall. To do this in Windows Firewall, run the firewall GUI by typing "firewall" into the start menu and clicking on the appropriate item, navigating to Outbound rules, clicking on New rule..., choosing Program, This program path and choosing the Dark Souls 2 executable, Block the connection, selecting all domains and giving the new rule an appropriate name. If you wish to enable multiplayer again, open this rule in the firewall GUI and change it to Allow the connection, and vice versa if you want to disable multiplayer. If you're using a 3rd party firewall instead of the built-in firewall, you likely know how to do the same in your firewall of choice, or you may google for instructions.

If for some reason you cannot do this, or you're playing on a console, you can always unplug your device or disconnect it from WiFi.

| improve this answer | |
  • If somebody can add the path to the executable I would be much obliged. – kotekzot Apr 27 '14 at 11:38
  • 1
    Assuming standard steam directory on 64-bit OS it will be in C:\Program Files (x86)\Steam\SteamApps\common\Dark Souls II\Game\DarkSoulsII.exe – jodag May 12 '15 at 3:20
0

If your on xbox live, start a party, you don't need to have anyone else in it, and it will put you into offline mode.

| improve this answer | |
0

This is not true, for PS3 there is a online and offline. And, yes, you can still be online without playing the online version. Now, here is how you do it:

Load up your game, once it starts hit the PS button and go to ACCOUNT MANAGEMENT. This is where you can sign in and out of your PSN account by hitting triangle. Being up the options menu SIGN OUT, then close this window by hitting the PS button again. Once having done this your Dark Souls 2 game will display a message stating, "you no longer are connected to the internet. Switching to offline mode".

Now all you do is repeat the process to sign back online once hitting the PS button to close out and return to your game. You will be able to continue playing offline but still able to actually be connected to the internet. Remember; this is for the PS3, this is unconfirmed on any other console or PC.

| improve this answer | |
  • Human effigies DO NOT guarantee you won't be invaded skilled players no its a waste to burn human effigy keep them for hollowing effect reversed – Joe Crail Jul 2 '14 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.