I'm playing the latest alpha build of Prison Architect (alpha-20) on Ubuntu 14.04 via Steam. My problem is that the game always crash when I save the game or when the auto-save is triggered.

At the end of the debug.txt file located in /home/epoc/.Prison Architect, I found several lines that seems to be interresting :

WARNING in Image constructor : Failed to open file ''
WARNING: Failed to activate checkbox 'SortBy'
WARNING: Failed to activate checkbox 'SortBy'
WARNING in Image constructor : Failed to open file '/home/epoc/.Prison Architect/saves/epoc.png'
Saving map to '/home/epoc/.Prison Architect/saves/epoc.prison'...Save completed in 254ms (219ms to serialise world, 34ms to write file)
Created FrameBuffer of size 2048 x 1024 in 0ms
(WorldRenderer::RenderCellTypes GL ERROR 0x501

It seems that the game cannot create the preview image file of my prison. Several people on the Web have this problem, but I didn't found any solution.

  • I tried a chmod 0777 on the save directory, change nothing. – Epoc May 9 '14 at 10:34
  • Also tried to manually create a dummy image file, the game still can't open it (but the image is shown on the Load game screen) – Epoc May 10 '14 at 10:02
  • 1
    I have the same issue and already reported a bug describing it. This bug only happens with the 64bit binary. Try running 32bit (~/.local/share/Steam/SteamApps/common/Prison\ Architect/PrisonArchitect.i686) from the terminal and see if it works. – Tim May 11 '14 at 9:34
  • This bug is now officialy fixed – Epoc Jun 23 '14 at 9:55

This bug was marked as fixed (awaiting feedback ATM) on the official PA bugtracker (the motherbug regarding all save crashs is located here).

Edit : This bug is now officialy fixed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.