1

I got a 32 gb flash drive and it was working just fine but when I git on and tried installing a update the flash drive didn't show up then i went to the storage and it was showing up there either i tried to plug it in somewhere else and turn off my xbox but nothing will work

  • 1
    This site is for video game questions and answers not console questions. – stizzle84 May 14 '14 at 1:24
  • 4
    This question looks fine to me. I'll work on an answer here in a minute for you. – agent86 May 14 '14 at 2:02
  • @Stizzle84 gaming hardware related questions are on topic AFAIK... – Jutschge May 14 '14 at 2:12
2

It's possible that you had hardware failure or that the files on your USB key have been corrupted.

What you can do to test this out is plug the USB key into your PC. The Xbox 360 uses a PC-compatible format for the device, so it should show up and be detected there.

If your PC doesn't recognize the device, or it gives an error, or it wants to format the USB key, then you've probably got a hardware failure on the key itself. Unfortunately, recovering the files is going to be challenging. The Xbox 360 writes special files to the USB key, and if they are damaged in any way, chances are the data is unrecoverable.

If you can mount the device on your PC and you see an "Xbox360" folder with a bunch of "Data0000" files in it, then it is likely that the USB key is working properly. That would seem to indicate that there's an issue with your Xbox 360.

You can try a different USB port, or try turning it off and back on again, or check for updates to the Xbox 360 system software. You could also try using another USB key to see if that works. If none of these things work, it probably indicates a problem with your Xbox 360 that can't be fixed. You will want to contact Microsoft support and see what they can do for you.

| improve this answer | |
  • Do not format the USB if this is so. Let me know. It's difficult though possible. – Brok3n May 15 '14 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.