0

At first I thought that the game itself just can't handle my setup as it has been released recently. Some guys may agree with that.

But I'm not happy with that. I do not get hard stuttering with my PC, but there has to be anything that I can get way more performance in ESO. I get around 30-60 FPS everywhere, no matter if I'm in a region where my graphics card gets stress-tested or has to rest.

When opening GPU-Z and the Taskmanager, I always see that my GPU only uses about half of it's capacity.

enter image description here

You can also see that my Fan Speed is at about 10%, which means that my GPU is sleeping while I play the game. Also my CPU got some capacity left, so that may not be the bottleneck.

In every other game I have no problem running at superultra-settings-and-beyond, but ESO seems to have a little personal warfare against me.

Sure there might be a performance patch or even an adjusted nVIDIA driver, but this more seems to me as I have to say my GPU that ESO is a game that needs juice.

How can I achieve a better performance?

Setup: AMD FX-8150 @stock GTX 670 DirectCU II @stock Game on SSD with space left Windows 8.1

  • I'd be careful about graphs running while the game isn't in focus. Some apps require less power when they aren't in the foreground; it's a "why waste power on rendering, if the window isn't visible?" optimisation technique. It's better if you log your hardware usage, play the game for a time, then quit the game and look at the logged values. – Nolonar May 14 '14 at 22:59
  • And there's the problem. ESO doesn't have a REAL fullscreen. It's more a borderless one. And I still get these graphs when playing in fullscreen and then switching out. As you see, the graph is stable on about 40-50% a long time. :) – Trollwut May 14 '14 at 23:38
3

The Elder Scrolls Online is very heavily bottlenecked by the CPU and there are some problems with the multithreading.

You should try the following:

  1. Set Power Profile to High Performance. This will make your CPU cores always run on full speed and in Windows 8 is disables core parking.

  2. Navigate to \Documents\Elder Scrolls Online\live (or \Documents\Elder Scrolls Online\liveeu for the EU client) and open the file UserSettings.txt and set the following line:

    SET RequestedNumWorkerThreads "-1"
    

to:

    SET RequestedNumWorkerThreads "0"

This will disable multithreading and is not a recommended setting; but it solved stuttering and FPS drops for some people.

Added:

  1. Disable 'Cool & Quiet' in your BIOS. High performance power profile SHOULD disable but there may be a problem in the BIOS implementation.

  2. Start TESO directly (eso.exe) and with admin privileges. Create a shortcut => right click => properties => advanced => activate admin privileges. This may help with some obscure driver based problems triggering the UAC.

  3. Enforce the use of your 'High Performance NVIDIA processor' for 'eso.exe'. Open Nvidia control panel => Manage 3D settings => 'Program Settings' => Select your 'eso.exe' and assign your 'High Performance NVIDIA processor'.

  • I indeed got about 3-4 FPS more, that's a pity. But this even is not enough to solve the problem. I really appreciate your answer! – Trollwut Jun 3 '14 at 10:29
  • @Trollwut In this case i would try to find out if only one of these measures is responsible for your FPS gain. Revert the setting in your UserSettings.txt to SET RequestedNumWorkerThreads "-1" and try if you have the same (or even better) FPS gain. That would be not unusual as 1. should give you always some slightly better performance (its more useful for CPU that are slow at at adjusting CPU frequency and parking/unparking cores), – Joe Scylla Jun 3 '14 at 12:56
  • Unfortunatelly I tried everything you posted once in a while. I also reverted RequestedNumWorkerThreads and did it again: I guess the performance "plus" was just because I restarted ESO and some data already has been in the RAM. As with High-priority setting for the GFX is also set, I more guess that the engine of ESO just doesn't want me to get the full experience. For now it seems that it is just poorly programmed... – Trollwut Jun 3 '14 at 21:20
1

It seems that The Elder Scrolls Online is just poorly optimized on Ultra settings and the performance you're getting seems to fall right where it should according to benchmarks of other setups. enter image description here enter image description here

Source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.