I have a packard bell gaming laptop. Its an i5 quad core, 12 gigs of ram. and a gtx 750m

The problem is that it has nvidia optimus(for those who dont know, Nvidia optimus is a feature that lets the intel hd graphics be the primary graphics processor while not using heavy 3D demanding apps and games.

Its good all round so far, the problem is that i just bought daylight (super keen) for $15 and the game wont run because when it checks for system specs, it uses the the intel gpu(which doesnt support dx11 apparently) instead of the gtx card.

Please help :(

  • Can you temporarily turn Optimus off? I know AMD has a similar feature, where you can "optimize game for performance" (GPU) or "optimize game for battery life" (IGP). – Nolonar May 15 '14 at 11:04
  • I have absolutely no idea how to do that with nvidia optimus. I went throught the geforce settings and couldnt find a function like that – Jonathan May 15 '14 at 12:29
  • 1
    Have you updated your drivers?. – Ulfric Stormcloak May 16 '14 at 3:01
  • I looked into that. I believe that may be the problem. There is an update for them in windows update but not in geforece(weird). I believe the drivers may be outdated. Just out of curiosity, would an older display driver not work with newer directx? – Jonathan May 16 '14 at 6:31
  • After updating my drivers and doing the bellow it worked with an issue that i left in the answers comments – Jonathan May 19 '14 at 7:17
up vote 1 down vote accepted

Model number of the laptop would help but on my packard either you can open intel integrated graphics settings and turn off "switching gpu to save power" or goto the power settings and turn off the change graphics card to save power.

Right clicking on desktop and selecting "configure switchable graphics" also works on my machine

Most laptops switch to dedicated gpu if you switch to high performance mode setting so try that as well...

Edit:I read that some of the newer laptops have a Fn key+dedicated button to switch between gpus, search if that applies for your model

http://www.tomshardware.com/answers/id-1988136/laptop-dedicated-gpu.html

while this info is for autocad, this page has a nice screenshot of switching the gpu in nvidia settings

http://knowledge.autodesk.com/search-result/caas/sfdcarticles/sfdcarticles/Crash-on-systems-with-integrated-Intel-HD-and-discrete-GPUs-Nvidia-AMD.html

  • It worked. I updated and could start the game. I'm not sure if i should make a new thread for the next question, while a new story loads i get an error of mvcr100.dll is missing. i did some research to this error and the solution came to reinstalling visual c++. I did that twice(64bit, 32bit) and it still didnt work. i did install them after testing to see if one install worked. – Jonathan May 19 '14 at 6:32
  • That isn't related to graphics card switching, it's a function of the version of visual c++ that the game uses. install the version of visual c++ that the game recommends and you should be golden – kkarakk May 21 '14 at 6:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.