20

In switching from residence life to house life for a brief vacation, I've been forced to downgrade from my 1920x1080 resolution-supporting monitor to a 1024x800 monitor, although I brought my computer along with me. I forgot to change the settings on my games to a lower resolution before heading out, and now whenever I try to open Starcraft 2, my screen goes black and I'm told that my monitor doesn't support the resolution.

Is there any way I can change the video settings outside of the game so I can resume playing Starcraft 2? If not, is there any way I can bypass this Black Screen Monitor Resolution Error Thing(TM) to play the game?

2
  • Have you tried running the repair utility in %INSTaLL_DIRECTORY%/Support? I haven't tried it for your use-case, but it should basically take you back to a default installation (including resolution settings).
    – Shaun
    Feb 20 '11 at 6:04
  • @Shaun This didn't work, sadly. I found another way, though! I'll post an answer.
    – Mana
    Feb 20 '11 at 6:31
19

Under My Documents/Starcraft II in Windows or ~/Library/Application Support/Blizzard/StarCraft II in Mac OSX (not the Starcraft II installation folder), there is a text file called Variables.txt which contains all the basic settings for the game, including graphics and sound options.

In this file, the variables height and width determine respectively the height and width in pixels of your game window on launch. Changing these from (in my case) 1080 and 1920 to 800 and 1024 fixed the problem.

4
  • 2
    This also works for Mac OS X. You can find the Variables.txt file in: ~/Libraray/Application Support/Blizzard/StarCraft II
    – bummzack
    Feb 21 '11 at 9:00
  • My SC2 installation on Mac OSX doesn't have a Blizzard folder under ~/Library/Application Support. Nor could I find Variables.txt anywhere.
    – LarsH
    Dec 10 '14 at 6:28
  • There is a /Users/Shared/Blizzard/Starcraft II folder, but it doesn't have Variables.txt in it. I'm running Yosemite if that matters.
    – LarsH
    Dec 10 '14 at 7:27
  • For 4K, changing width to 3840 and height to 2160 worked for me.
    – Webber
    Jul 19 '21 at 17:35
4

Pressing alt+enter (Windows) or +M (Mac OS X) should make the game run in windowed mode. The key-combination should usually work as soon as the login dialog appears, so you might have to wait a short period of time.

Once the game runs in windowed mode, you should be able to go to the settings and change your display resolution, then switch back to fullscreen.

1
  • 1
    Sadly, this didn't work for me on a fresh SC2 install.
    – McKay
    Oct 8 '12 at 2:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.