6

I'm trying to play Watchdogs, however, EVERY time I try and open Uplay it crashed, I've tried reinstalling, restarting my PC, restartinig my PC between each step of reinstalling Uplay and everytime it crashed on logging in. Is this a current bug or is this actually fixable?

Here's a screenshot of the dump fileenter image description here

3
  • I've had this recently too when I tried to get The Mighty Quest For Epic Loot working ... I recall fixing my problem after browsing a number of forum posts. I'll see if I can find the post again. – Sadly Not May 27 '14 at 18:27
  • I remember the UPlay uninstaller being really sloppy, can you check that it left no files behind in C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher? I would try reinstalling and then restarting your computer after that. Pending a better answer ... – Sadly Not May 27 '14 at 18:43
  • From what I understand, UPlay was breaking today. Perhaps it doesn't know how to fail gracefully, and it just up and dies on you? – Frank May 28 '14 at 4:08
10

Here's what I found on the Steam forum, it seems to be working for quite a few people:

  • I uninstalled Uplay entirely. It leaves files behind! Go to your \program files (x86)\ folder and delete the Ubisoft folder there completely. This was necessary for me to do
  • I restarted my computer (had to do this too, no restart after removal/installation did nothing for me before)
  • I re-installed Uplay using the installer found on Uplay's website.
  • After installation, I restarted again.
  • I launched the game through Steam and after about a minute, Uplay finally came up without crashing and updated itself.
  • Exit Uplay.
  • Re-launch the game through Steam again, and now you can input your key to activate it.

UPDATE: I just used this method to use uPlay, and it worked! Just a quick note, when you first launch the game through Steam it will say it is installing uPlay. Just let it run, and it will end up launching and likely will not need to update itself

Source

7
  • Do you have a link to this? Attribution is important (and ensures we know who did what). – Frank May 27 '14 at 21:24
  • Here is a link to the full forum, the comment I got the solution from is on this page steamcommunity.com/app/235600/discussions/0/846962439208487864 – Adam May 27 '14 at 21:43
  • @Adam Couldp you edit that in? – peper757 May 27 '14 at 21:44
  • Much appreciated. – Frank May 27 '14 at 21:45
  • @peper757 there should be a source button towards the bottom of my original post, click that and it should take you to the Steam forum – Adam May 27 '14 at 21:46
1

According to this thread on Steam, there's an even easier solution that doesn't require you to uninstall UPlay and restart your machine:

Try:

Go in "C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher" then right click on "Uplay.exe" and lauch as admin, and compatibility Windows 7 (I'm running Win 8)

Start Uplay with the changed settings and log in

You'll then need to login to UPlay and activate your game with its game key.

Not the answer you're looking for? Browse other questions tagged or ask your own question.